Why does Little registry cleaner not backup-up selected reg entries before deleting them - it used to do this.

Asked by Jerry on 2010-04-03

I am running MS Widows Vista Ultimate SP2 w/all fixes applied.
I have been using Little Registry Cleaner for several months. When I first installed it, it would backup all registry entries before deleting them.
Now it does not perform this function. My saved entries are 2 .xml files dated November 2009.
I have checked all configuration settings and other than System Restore points, there is no mention of backing up entries.
I just installed the latest revision and received the same result. Can you suggest a fix? Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Little Registry Cleaner Edit question
Assignee:
Nick Edit question
Solved by:
Nick
Solved:
2010-04-09
Last query:
2010-04-09
Last reply:
2010-04-09
Nick (ub3rst4r) said : #1

Hi, If you are using the newest version (v1.4.1) the backup system should be working correctly. Can you open up LRC and go to Tools -> Options and tell me if "Log registry scans and fixes" is checked. Thanks!

Jerry (gbchandler) said : #2

Hi Nick:
Yes, I am using the latest version 1.4.1, and yes, the box is checked
for the "Log Registry scans and fixes". I have reinstalled and still do
not get a backup.

Thanks for the prompt reply!

On 4/3/2010 2:11 PM, Nick wrote:
> Your question #106323 on Little Registry Cleaner changed:
> https://answers.launchpad.net/lilregcleaner/+question/106323
>
> Status: Open => Needs information
>
> Nick requested for more information:
> Hi, If you are using the newest version (v1.4.1) the backup system
> should be working correctly. Can you open up LRC and go to Tools ->
> Options and tell me if "Log registry scans and fixes" is checked.
> Thanks!
>
>

Nick (ub3rst4r) said : #3

Do you know what version you were using when it worked?

Jerry (gbchandler) said : #4

To get an answer to your question, I had to dig a little, which I should
have done in the first place before I asked for help.
I discovered that while the .txt files were being placed into the LOG
sub folder, all the .xml files are being place into the root,
'Little Registry Cleaner' directory. I moved them all the to 'BACKUPS'
sub folder and everything worked fine. I completed a restore and then
removed it. After the restore it did delete the .xml file from the
'backups' sub directory.
When I removed it, the .xml file again went into the root directory.

Is there a way to limit the number of .txt and .xml files ? I have 57
.txt files and 44 .xml files. I do have the option checked to delete the
backup after a restore has been completed.
The oldest copy of Little Registry Cleaner I can find an entry for was
1.4, used on 11/16/09.

On 4/4/2010 2:08 PM, Nick wrote:
> Your question #106323 on Little Registry Cleaner changed:
> https://answers.launchpad.net/lilregcleaner/+question/106323
>
> Status: Open => Needs information
>
> Nick requested for more information:
> Do you know what version you were using when it worked?
>
>

Best Nick (ub3rst4r) said : #5

Hi,

The reason the backup files were being placed in a different directory is because v1.4 had the internal setting incorrect. This caused v1.4.1 to read this setting and automatically backup the files to this directory. I released v1.4.0.1 just shortly after v1.4 was released to address this issue. There currently isn't a way to limit the number of log and backup files created, however, I will add this to the list of blueprints.

- Nick

Jerry (gbchandler) said : #6

Thank you for the assistance, Nick. The problem is resolved.