Timeout error occurs when submitting bug report in Launchpad

Asked by David R. Bergstein on 2019-01-08

Here is a copy of the error just observed:

Timeout error

Sorry, something just went wrong in Launchpad.

We’ve recorded what happened, and we’ll fix it as soon as possible. Apologies for the inconvenience.

Trying again in a couple of minutes might work.

(Error ID: OOPS-730a7c1f55ad1e871b49ee8f39065ed1)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2019-01-26
Last query:
2019-01-26
Last reply:
2019-01-23
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

David R. Bergstein (dbergst) said : #2

Can someone please investigate this issue?

On Wed, Jan 23, 2019, 3:59 AM Launchpad Janitor <
<email address hidden> wrote:

> Your question #677390 on Launchpad itself changed:
> https://answers.launchpad.net/launchpad/+question/677390
>
> Status: Open => Expired
>
> Launchpad Janitor expired the question:
> This question was expired because it remained in the 'Open' state
> without activity for the last 15 days.
>
> --
> If you're still having this problem, you can reopen your question either
> by replying to this email or by going to the following page and
> entering more information about your problem:
> https://answers.launchpad.net/launchpad/+question/677390
>
> You received this question notification because you asked the question.
>

Colin Watson (cjwatson) said : #3

We know about this problem, which has been around for some time, but it's resisted investigation. We believe that an upcoming upgrade to a newer version of PostgreSQL will help.

In any case, this particular category of timeout is always a fairly short-lived transient thing, so in terms of a support request the simplest answer is to wait ten minutes and try again.

David R. Bergstein (dbergst) said : #4

Based on my observation, this problem is worse than that described by Colin Watson. I have been trying to submit a bug since mid-December and have never been able to get past the timeout.

Best Colin Watson (cjwatson) said : #5

Ah, apologies. I've just re-read your OOPS and I see the problem is not what I first thought it was.

The problem is that in the "In what package did you find this bug?" field, you've entered "linux-modules-4.18.0-13-lowlatency". This form in fact wants a *source* package name, and when it doesn't get one it falls back to searching all bugs in Ubuntu at one point in the form processing, which times out.

Now, this behaviour is certainly a bug (specifically https://bugs.launchpad.net/launchpad/+bug/1635118, I believe), and we should fix it. But from your end there are two possible workarounds to let you at least file the bug:

 * Instead of entering the package name directly, you can press the search icon to the right of that text entry box and enter the package name there; that will search for it and give you a list of source package names to choose from. If you select one of those (probably "linux") then it will enter that for you and you should be able to file the bug.
 * Alternatively, you can just enter "linux" directly.

David R. Bergstein (dbergst) said : #6

Thanks Colin Watson, that solved my question.