Rejected: Unable to find distroseries: experimental

Asked by Leon Nardella on 2009-01-28

Just made my first upload to a PPA and got this email:

Unable to find distroseries: experimental
Further error processing not possible because of a critical previous error.

amule (2.2.3-1) experimental; urgency=low

 * "The Cactus Where Your Heart Should Be" release.

 * New upstream release. (Closes: #510257)
   + drop manpages_spelling_fixes.diff, merged upstream.

 * Bump debian/compat to 5.
 * Change section of packages to net (from x11, heh).
 * Add a paragraph to amule-daemon/README.Debian about its init script.

Date: Sat, 03 Jan 2009 13:00:48 +0100
Changed-By: Adeodato Simó <email address hidden>
Signed-By: Leon Nardella <email address hidden>

Not really sure what is wrong.
I guess 'experimental' is related to Debian experimental, so I should try to stick Intrepid there, but I don't know how.

Any help is welcome.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Celso Providelo
Last query:
Last reply:
Best Celso Providelo (cprov) said : #1


There is no 'experimental' series in ubuntu. You have to modify the debian/changelog to point to a ubuntu series (hardy, intrepid, jaunty, etc).

Or, if you feel comfortable in creating new dput targets, you can use the hint described in for overriding the original source series while uploading it.

Leon Nardella (leon.nardella) said : #2

Thanks for you hin, Celso.

I tried it and, at first, dput wouldn't let me upload the package, saying:

leon@alderaan:~/Sources/amule$ dput ppa amule_2.2.3-1_source.changes
Already uploaded to
Doing nothing for amule_2.2.3-1_source.changes

But I could work around this with the '-f' parameter:
$ dput -f ppa amule_2.2.3-1_source.changes

I'm waiting for the result, now.
If all goes well, I'm gonna mark this solved. :)

Leon Nardella (leon.nardella) said : #3

Thanks Celso Providelo, that solved my question.

Thorsten Glaser (mirabilos) said : #4

+1, thanks

Thorsten Glaser (mirabilos) said : #5

Thorsten Glaser suggests this article as an answer to your question:
FAQ #227: “Why has the package I dput-ed into my team's PPA not shown up yet?”.