Sourceforge FreeCAD svn import fails over http

Asked by Normand C


The VCS Import from Sourceforge svn for has been suspended after 5 import failures. The last successful import was on 09/25. All the failures end with this:

File "/srv/", line 149, in convert
    raise mapped_err
bzrlib.plugins.svn.errors.DavRequestFailed: A Subversion remote access command failed: REPORT of '/svnroot/free-cad/!svn/vcc/default': Could not read response body: Connection reset by peer (
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

We previously had 4 consecutive failures last month but the situation resolved itself without intervention.

This VCS import was set up back in 2009 over http. I've noted a previous answer where it is said that http is more reliable than https:

Considering our import's age, I'm guessing it's using CSCVS, while it seems new imports are done through bzr-svn which may be more reliable if I'm to believe this other answer:

I'm pasting the relevant comment below:
Tim Penhey (thumper) said on 2010-11-07:

The underlying problem here is this one: Connection reset by peer (

The import is using CSCVS to import the code. This has known speed issues.

All new imports use bzr-svn, which is much faster and likely to be fine. The difference is that a new import using bzr-svn will not have common history with the existing import.

Sorry for the long preamble, my question is specifically this:

- If our import is indeed CSVCS, what are the steps needed to change it to bzr-svn? Do we have to delete the existing imported branch and request a new one? Or can the existing one be switched somehow?
- What would the history loss entail on the bzr revision number? Would they be reset to smaller numbers than existing? Since we provide autobuild daily testing packages and use the bzr numbering in our package versioning, this could cause some inconvenience.

Thank you.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Max Bowsher
Last query:
Last reply:
Revision history for this message
Best Max Bowsher (maxb) said :

* The current import is not via CSCVS, it's via bzr-svn.

* http used to be more reliable than https, but since then they've made their https server better and their http server worse. The reverse is now true. I've switched the import to https and now it works.

Revision history for this message
Normand C (gemnoc) said :

Thanks Max Bowsher, that solved my question.