Automatic import from svn repository at SourceForge fails

Asked by Roland Clobus

See for the log about my latest attempt to manually start the automatic import.

The import of the subversion repository that is hosted on SourceForge fails.
The last import was 2010-10-26, and that same the the import started to fail.

With kind regards,
Roland Clobus
Developer for Pioneers

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Tim Penhey
Last query:
Last reply:
Revision history for this message
Curtis Hovey (sinzui) said :

This is a question

Revision history for this message
Roland Clobus (rclobus) said :

The most relevant part in the log file is:
Traceback (most recent call last):
  File "/srv/", line 82, in <module>
  File "/srv/", line 77, in main
  File "/srv/", line 452, in run
    return self._doImport()
  File "/srv/", line 536, in _doImport
    self.importToBazaar(foreign_tree, bazaar_branch)
  File "/srv/", line 514, in importToBazaar
    foreign_directory, "-SC", "%s::" % last_commit, bzr_directory)
  File "/srv/", line 531, in _runToBaz
    totla.totla(config, self._logger, config.args, SCM.tree(source_dir))
  File "/srv/", line 252, in totla
    apply_changeset(source_tree, logger, apply, revision, target_tree, revisions)
  File "/srv/", line 122, in apply_changeset
    fileChange.apply(logger, target_tree, prune)
  File "/srv/", line 32, in apply
    target_tree, self.relpath(), self.url(), self.revision)
  File "/srv/", line 91, in writeFile, revision=revision.rev),
pysvn._pysvn_2_6.ClientError: GET of '/svnroot/pio/!svn/bc/1596/trunk/pioneers/po/nl.po': Could not read response body: Connection reset by peer (
Exception AttributeError: "'NoneType' object has no attribute 'close'" in <function terminate at 0x448caa0> ignored

This indicates that the code running on Launchpad crashes/throws an exception.
To me, that indicates a bug, not a user question.

Revision history for this message
Best Tim Penhey (thumper) said :

The underlying problem here is this one: Connection reset by peer (

The import is using CSCVS to import the code. This has known speed issues.

All new imports use bzr-svn, which is much faster and likely to be fine. The difference is that a new import using bzr-svn will not have common history with the existing import.

Revision history for this message
Roland Clobus (rclobus) said :

I've requested an import again, for the second time.
It appears to work now.

Revision history for this message
Roland Clobus (rclobus) said :

Thanks Tim Penhey, that solved my question.