Launchpad could not import your OpenPGP key.

Asked by Eliumara Lopez on 2011-02-14

Hi
I keep getting the error:
"Launchpad could not import your OpenPGP key:
    * Did you enter your complete fingerprint correctly? (Help with fingerprints)
    * Is your key in the Ubuntu keyserver yet? You may have to wait between ten minutes (if you pushed directly to the Ubuntu key server) and one hour (if you pushed your key to another server). (Help with publishing keys)"

I followed all the steps as given in :
https://help.launchpad.net/ImportingYourOpenPGPKey
After, I still get the mentioned error.
Please helps me registering my key with launchpad.
Thanks
Ely

Question information

Language:
German Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Curtis Hovey
Solved:
2011-02-15
Last query:
2011-02-15
Last reply:
2011-02-15

Can you please paste your key ID here and I'll check it.

Key ID: 9FD72197 for <email address hidden>

Your key is not in the keyserver - please try exporting/pushing it to keyserver.ubuntu.com again.

Cecchip (cecchip) said : #4

I have this problem!
Please helps me also to me!
My key ID is 4300BCDF for <email address hidden>
Thanks

Thank Julian
Sorry i try again: select Remote > Sync and Publish Keys from the menu. Choose the Sync button" it to keyserver.ubuntu.com and the next steps for register my key with launchpad, but still without happening!

Max Bowsher (maxb) said : #6

@Eliumara:

According to this query:
http://keyserver.ubuntu.com:11371/pks/lookup?search=0x9FD72197&op=vindex
it looks like your key is now present on the keyserver - please try the key import again.

@Cecchip:

Your key is *not* in the keyserver, you need to send it there. However, please also follow the advice that appears at the bottom of each question webpage: "Got a question of your own? For best results, ask your own question separately." This will help track the differing status of your issue and Eliumara's.

Thank
I try the key import again but I still get the mentioned error persists! :-(

The only other possible problem is that you are not telling Launchpad to import the same key that is in the keyserver.

This isn't possible, I have created only one OpenPGP key in the keyserver!
Now I create an other key and I try again...

Two keys created in the keyserver:
http://keyserver.ubuntu.com:11371/pks/lookup?search=lopez.eliumara&op=vindex
but still without happening!
helps me please

On Monday 14 February 2011 15:20:51 you wrote:
> Question #145328 on Launchpad itself changed:
> https://answers.launchpad.net/launchpad/+question/145328
>
> Eliumara Lopez posted a new comment:
> This isn't possible, I have created only one OpenPGP key in the keyserver!

Do you only have one on your local PC?

> Now I create an other key and I try again...

Wait a moment before you do that, let's dig further,

Ok, let's step through this. Please paste here what you are selecting as your "fingerprint" text.

Key fingerprint = 252D 8830 10F6 48C9 88D2 B1BE C44D 183F 9FD7 2197
Key ID: 9FD72197 for <email address hidden>

I paste alone the "Key fingerprint" on the text box

When you paste the fingerprint, make sure it has no spaces in, so like this:

252D883010F648C988D2B1BEC44D183F9FD72197

continues the same error, to cancel the spaces doesn't chance nothing...I have tried

Best Curtis Hovey (sinzui) said : #17

I believe canonical's internal keyserver is having difficulties syncing with keyserver.ubuntu.com. Your key was not there a few hours ago. I am told it is now. So instead of syncing in 10 minutes, the sync took 10 hours. Try registering your key now.

Yes finally! my Key pending validation on Launchpad...today!
Curtis Hovey has reason, the sync require 10 hours or +....instead of syncing in 10 minutes!
Thanks all

Thanks Curtis Hovey, that solved my question.