Rebuild never starts (shows "Start in 6 minutes" even though i386 builders are idle!)

Asked by James Hunt on 2010-12-17

I'm trying to build packages in my PPA for a release bug:

https://launchpad.net/~jamesodhunt/+archive/cerulean/+packages

Build was failing on util-linux (claimed to be a "chroot problem", although the actual problem is with the util-linux pkg I think). I tried rebuilding, but status for i386 shows "Start in 6 minutes". It's being showing that for hours now, even though the builders are idle.

Please can you:

- get my util-linux build kicked off
- give me access to some more diagnostic info to determine what is causing the build failure. Ideally I'd like to see what this command returns:

  grep "Forcing re-swapon" /var/log/messages

Thanks,

James.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2010-12-17
Last reply:
2010-12-17

> Build was failing on util-linux (claimed to be a "chroot problem", although
> the actual problem is with the util-linux pkg I think). I tried
> rebuilding, but status for i386 shows "Start in 6 minutes". It's being
> showing that for hours now, even though the builders are idle.
>
> Please can you:
>
> - get my util-linux build kicked off

The start estimation is completely wrong for some reason, there's a very large
queue of builds waiting and you need to wait in line.

> - give me access to some more diagnostic info to determine what is causing
> the build failure. Ideally I'd like to see what this command returns:
>
> grep "Forcing re-swapon" /var/log/messages

We would need a build log to determine where the failure lies.

I just found another of your builds, it's saying there's a problem:

dpkg: error processing util-linux (--configure):
 subprocess installed post-installation script returned error exit status 1

Since this is natty it could have a transient issue - chat to the distro guys.

James Hunt (jamesodhunt) said : #3

Please can you send me the grep output as the problem could be related to the changes I've made in the util-linux pkg.

Thanks,

James

On Friday 17 December 2010 10:50:34 you wrote:
> Question #138095 on Launchpad itself changed:
> https://answers.launchpad.net/launchpad/+question/138095
>
> James Hunt posted a new comment:
> Please can you send me the grep output as the problem could be related
> to the changes I've made in the util-linux pkg.

Unfortunately that's not possible on the virtual builders, there's no shell
access.

Can you help with this problem?

Provide an answer of your own, or ask James Hunt for more information if necessary.

To post a message you must log in.