Why does my PPA fail silently? ppa:t-w-/ppa, backtestground_0.1-0ubuntu1

Asked by thorwil on 2010-12-07

Building a binary package from the source package works locally, but nothing happens even hours after
dput ppa:t-w-/ppa backtestground_0.1-0ubuntu1_source.changes

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Julian Edwards
Solved:
2010-12-08
Last query:
2010-12-08
Last reply:
2010-12-08

Julian Edwards suggests this article as an answer to your question:
FAQ #227: “Why has the package I dput-ed into my team's PPA not shown up yet?”.

thorwil (t-w-) said : #2

#227 is why this question exists:
"If, after checking all of these items, you are still getting a problem, please file a Question stating your package name and your PPA page URL and someone will check for problems on the Launchpad side."

While I have no doubt it's some little detail or oversight, I checked all I could and can't get any further without even an error message.

Unfortunately you didn't read the FAQ properly, you're signing your upload with a key that is not in Launchpad.

thorwil (t-w-) said : #4

The fact that I only have one key and use it all the time for bzr push to LP made me think this couldn't be the issue.

I now see LP lists a different keyID. Guess because I added an uid later on? Now I'm puzzled why this still works in the bzr case, but not here.

Thanks!

> I now see LP lists a different keyID. Guess because I added an uid later
> on? Now I'm puzzled why this still works in the bzr case, but not here.

bzr uses ssh keys, package signing uses gpg keys.

> Thanks!

Welcome!

thorwil (t-w-) said : #6

Thanks Julian Edwards, that solved my question.