DXF files are not visibe when imported

Asked by Steve Tagg on 2018-10-11

When I try to import a DXF file it is either invisible although the title bar shows the filename, or it is enormous, e.g. over 4 metres for a drawing of 170mm.
The DXF files have been drawn by me in QCAD.
The maximum size of a drawing I would try to import is 300mmx200mm as this is the cutting area of my laser machine.
I have tried changing the import scale settings, but they seem to have no effect.

The reason I want to import into inkscape is to change the colour of the drawing lines so that they are recognized correctly in K40 Whisperer, which is my laser control program.

Any suggestions would be much appreciated.

Thank you,

Steve.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Hachmann
Solved:
2018-10-15
Last query:
2018-10-15
Last reply:
2018-10-14
Hachmann (marenhachmann) said : #1

Can you share a file and also make a screenshot of your import settings?

Please upload those to a file hoster of your choice, and share the links. Attachments are not supported here.

Steve Tagg (carloss2305) said : #2

I have put the files requested in a folder called Inkscape in my dropbox.
The link is
https://www.dropbox.com/sh/7dlsqnzqli9eq5j/AADWZaKCAdqEe4l7qukTp8wPa?dl=0

Hope this helps

Sent from Windows Mail

From: Hachmann<mailto:<email address hidden>>
Sent: ‎Thursday‎, ‎11‎ ‎October‎ ‎2018 ‎23‎:‎00
To: <email address hidden><mailto:<email address hidden>>

Your question #675069 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/675069

    Status: Open => Needs information

Hachmann requested more information:
Can you share a file and also make a screenshot of your import settings?

Please upload those to a file hoster of your choice, and share the
links. Attachments are not supported here.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/inkscape/+question/675069

You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #3

Please convert the file(s) into the supported DXF version, or already export them in the optimal format.

Inkscape supports DXF R13 (and higher, it seems) for opening (see the dropdown in the File > Open dialog).

Opening the file in LibreCad, saving as DXF R14, and then reopening in Inkscape worked for me.

Hachmann (marenhachmann) said : #4

At least, mostly. Not perfectly, some shapes seem to be missing or moved, at the ends.

Steve Tagg (carloss2305) said : #5

I have done what you suggested and yes it works apart from the missing bits. The missing bits (coloured red) came from a different DXF and were pasted on. I suspect this could be why they are not displayed correctly.
However, the drawing is opening in Inkscape approximately 4 times its original size. The original drawing is roughly 158x44 mm. It seems we have another problem.

Thank you for your help and effort.

Sent from Windows Mail

From: <email address hidden><mailto:<email address hidden>>
Sent: ‎Friday‎, ‎12‎ ‎October‎ ‎2018 ‎13‎:‎32
To: <email address hidden><mailto:<email address hidden>>

Your question #675069 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/675069

Hachmann posted a new comment:
At least, mostly. Not perfectly, some shapes seem to be missing or
moved, at the ends.

--
You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #6

1. I get a different result, but I am using Inkscape 0.92.x, the stable development branch. Are you using 0.92.3, or some earlier Inkscape version? Note that I *open* the file with Inkscape, I do not import it.

2. As another test, I saved as MakerCAM SVG from LibreCAD. This keeps all parts in the file, but I get a size of 168 mm, which needs to be divided by 96, then multiplied by 90, to get the correct size. This is because the other program seems to assume a resolution of 90 dpi, while Inkscape uses the CSS standard resolution of 96 dpi.

3. (Best option so far) However, I've found a better option. I saved as pdf from LibreCAD.
This:

- keeps all elements
- imports in the correct size in Inkscape
- adds groups, and due to inefficient code in Inkscape, ungrouping takes ... eternally. Don't use Inkscape's normal ungroup if you need to ungroup a group that holds many (> 100) objects! Use Extensions > Arrange > Deep Ungroup instead, that is much, much more efficient.

Steve Tagg (carloss2305) said : #7

Thank you Hachmann.
I am using version 0.92.
Your solution version 3 works. All elements are present and the size is correct! Hooray!
However (isn’t there always a however?) I need to make all the lines in the drawing red, or my laser software will only cut the red bits and engrave the rest.
I know this seems bizarre, but the idea is to be able to engrave and cut all in the same run.

Sorry to be a nuisance, but thanks to your help I am making progress and learning at the same time.
Thanks again for your help and support.
carloss.

Sent from Windows Mail

From: <email address hidden><mailto:<email address hidden>>
Sent: ‎Friday‎, ‎12‎ ‎October‎ ‎2018 ‎23‎:‎56
To: <email address hidden><mailto:<email address hidden>>

Your question #675069 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/675069

    Status: Open => Answered

Hachmann proposed the following answer:
1. I get a different result, but I am using Inkscape 0.92.x, the stable
development branch. Are you using 0.92.3, or some earlier Inkscape
version? Note that I *open* the file with Inkscape, I do not import it.

2. As another test, I saved as MakerCAM SVG from LibreCAD. This keeps
all parts in the file, but I get a size of 168 mm, which needs to be
divided by 96, then multiplied by 90, to get the correct size. This is
because the other program seems to assume a resolution of 90 dpi, while
Inkscape uses the CSS standard resolution of 96 dpi.

3. (Best option so far) However, I've found a better option. I saved as pdf from LibreCAD.
This:

- keeps all elements
- imports in the correct size in Inkscape
- adds groups, and due to inefficient code in Inkscape, ungrouping takes ... eternally. Don't use Inkscape's normal ungroup if you need to ungroup a group that holds many (> 100) objects! Use Extensions > Arrange > Deep Ungroup instead, that is much, much more efficient.

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/inkscape/+question/675069/+confirm?answer_id=5

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/inkscape/+question/675069

You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #8

Can you rephrase the question? I don't understand what must be red and black etc.

I assume you already know how to select everything, and to change the selection's stroke color, so you're probably asking for something else.

Steve Tagg (carloss2305) said : #9

Sorry Hachmann, I do know how to change the stroke color.
I had completely forgotten with all the different software being used.

The problem is solved! I just need to remember how to do it (I do not always have internet access - I live on a boat).

Thank you for your help.

carloss.

Sent from Windows Mail

From: <email address hidden><mailto:<email address hidden>>
Sent: ‎Saturday‎, ‎13‎ ‎October‎ ‎2018 ‎21‎:‎52
To: <email address hidden><mailto:<email address hidden>>

Your question #675069 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/675069

    Status: Open => Needs information

Hachmann requested more information:
Can you rephrase the question? I don't understand what must be red and
black etc.

I assume you already know how to select everything, and to change the
selection's stroke color, so you're probably asking for something else.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/inkscape/+question/675069

You received this question notification because you asked the question.

Best Hachmann (marenhachmann) said : #10

There's a free manual available online (http://write.flossmanuals.net/start-with-inkscape/_draft/_v/2.10/why-use-inkscape/) of which I am the main translator and organizer.

I've been wanting to create a current pdf file of it for you, so you can take it with you on board, but export is currently broken.

This one is from March:
https://framadrive.org/s/yTXkRxxPm66NxXR

Steve Tagg (carloss2305) said : #11

Thank you Hachmann for your help and perseverance in finding a solution to my problem.