Can't edit with mouse in INKSCAPE 0.92.2 (5C3E80D.2017-08-06)

Asked by PAUL R FONTENOT on 2018-10-02

When I first installed Inkscape in my iMac, I could edit with my mouse; now I can only use the mouse as a selection tool, picking individual tools and navigating windows, but I cannot do any editing on the canvas whatsoever.

I can only have full functional behavior using the graphics tablet.

This is a constant problem; it always happens.

I have reinstalled Inkscape, with no solution.

I have reinstalled the mouse drivers, with no solution.

I have looked for other bug reports with this phenomena, but I can't find any relevant issues like this.

I can't provide a screenshot because there is nothing to take a screenshot of; the mouse simply will not edit the canvas!

Using Mac OS High Sierra 10.13.6

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
PAUL R FONTENOT
Solved:
2018-10-09
Last query:
2018-10-09
Last reply:
2018-10-03

Does anyone else out there have problems editing the canvas with your mouse in Inkscape 0.92.2 on Mac running OS High Sierra?

Any solutions within the community?

Hachmann (marenhachmann) said : #2

You could play a bit with the settings for the mouse in the Input devices settings.

However, I always thought this was normal - I couldn't use the mouse on canvas either while the graphics tablet was plugged in (this is on Linux Mint, haven't tested again for a long time).

As these settings are saved in the preferences, and you say it's new, you could try closing Inkscape, then renaming your personal preferences file (Location: see Edt > Preferences > System > user preferences).

Thanks, Hachman for trying to help.

I have restarted Inkscape several times with no change.

I have turned on and off, the tablet settings in preferences; no changes to the tablet functions on either setting; the tablet performs the same no matter whether the tablet settings are turned off or on.

The mouse cannot edit the canvas no matter which way the tablet settings are; on or off.

I don't understand how changing the name of my system preferences is supposed to work; I am scared that if I change the name of my system settings, that the links between all of the programs to system preferences will be lost; please elaborate on how to do this without impacting other applications. Also, step by step instructions on how to rename system preferences and creating a new system preference file would be helpful.

Hachmann (marenhachmann) said : #4

Yes, restarting won't make a difference.

For the mouse, you would need to modify the core pointer settings, not the tablet settings, in the input devices dialog (but as I said, I think it won't help).

Renaming the preferences.xml file will just make Inkscape create a new one. Your preferences for Inkscape will be lost, but you can restore them if you name the file back to its original name.

Look for its location in the indicated place (in Inkscape): Edit > Preferences > System > User preferences.
Or read more details here:
https://inkscape.org/en/learn/faq/#how-reset-user-preferences

Hachmann (marenhachmann) said : #5

Or rather, restarting does make a difference, if the status of the tablet (plugged in or not) is different.

This may not have any connection to my local installation of Inkscape, but I am able to edit the canvas on the online version of Inkscape in the Rollapp website.

Hackmann, I restarted Inkscape twice, once with the tablet plugged in and once with it not plugged in and it made no difference to my mouse being able to edit the canvas.

I renamed the preferences.xml file and it made no difference; Inkscape did create a new preference file but it made no difference.

I even went so far as going through the preferences.xml file, line by line and could not find where it addressed input devices.

Do you know of another config file that might address input devices?

I just uninstalled and reinstalled Inkscape; same results; still can't edit the canvas!

Hachmann (marenhachmann) said : #9

Mmmh. Maybe the tablet's status is cached somewhere, even when you plug it out?

One last thing I'd try is:

- unplug tablet
- restart computer
- start Inkscape

If that also doesn't help, please:

- create a thread on the inkscape-user mailing list:
https://sourceforge.net/p/inkscape/mailman/inkscape-user/

or

- reopen your bug report and summarize the info about what you tried into its description.

I uninstalled Inkscape, Quartz & McPorts just to see if the settings would go away when I reinstalled Inkscape.

Could not run Inkscape without having to reinstall Quartz.

When I reinstalled and launched Inkscape, all the settings that were in Inkscape from before were automatically loaded into the new installation; there has to be another place where these settings are located; I am dumbfounded as the where that location might be.

<email address hidden>

337-322-4442

105 ISLAND NEST CV
CARENCRO LA 70520-5856

> On Oct 4, 2018, at 05:37, Hachmann <email address hidden> wrote:
>
> Your question #674609 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/674609
>
> Hachmann posted a new comment:
> Mmmh. Maybe the tablet's status is cached somewhere, even when you plug
> it out?
>
> One last thing I'd try is:
>
> - unplug tablet
> - restart computer
> - start Inkscape
>
> If that also doesn't help, please:
>
> - create a thread on the inkscape-user mailing list:
> https://sourceforge.net/p/inkscape/mailman/inkscape-user/
>
> or
>
> - reopen your bug report and summarize the info about what you tried
> into its description.
>
> --
> You received this question notification because you asked the question.

I went back to the preferences.xml file and made the changes below:

Nothing changed: still can’t edit the canvas.

I tried to edit the canvas both with my wireless trackball and my wired mouse.

    <group
       id="P:pen" changed to read: id=“M:mouse”
       mode="screen"
       axes="x;y;pressure;xtilt;ytilt"
       keys="" />

<email address hidden>

337-322-4442

105 ISLAND NEST CV
CARENCRO LA 70520-5856

> On Oct 3, 2018, at 20:47, Hachmann <email address hidden> wrote:
>
> Your question #674609 on Inkscape changed:
> https://answers.launchpad.net/inkscape/+question/674609
>
> Hachmann posted a new comment:
> Yes, restarting won't make a difference.
>
> For the mouse, you would need to modify the core pointer settings, not
> the tablet settings, in the input devices dialog (but as I said, I think
> it won't help).
>
> Renaming the preferences.xml file will just make Inkscape create a new
> one. Your preferences for Inkscape will be lost, but you can restore
> them if you name the file back to its original name.
>
> Look for its location in the indicated place (in Inkscape): Edit > Preferences > System > User preferences.
> Or read more details here:
> https://inkscape.org/en/learn/faq/#how-reset-user-preferences
>
> --
> You received this question notification because you asked the question.

Hachmann (marenhachmann) said : #12

If you don't want to report a bug or ask on the mailing list, but want this to stay here, then please share screenshots of your input devices dialog, one for each device in the list (Edit > Input devices).

Also let us know which different settings you tried. Changing them always requires a restart of Inkscape.

For sharing screenshots, please use an image hosting website, like imgur, for example.

SOLVED!

Changing the mode from “screen” to “0” enabled the mouse!

17:22 10/05/2018

/Users/"name"/.config/inkscape/prefences.xml

Changed:

  <group
     id="devices">
    <group
       id="M:mouse" from: id=“P:pen”
       mode="0" from: “screen
       axes="x;y;pressure;xtilt;ytilt"
       keys="" />
    <group
       id="C:cursor"
       mode="0" from: “screen”
       axes="x;y;pressure;xtilt;ytilt"
       keys="" />
    <group
       id="E:eraser"
       mode="0" from: “screen”
       axes="x;y;pressure;xtilt;ytilt"
       keys="" />