Inkscape unable to show dropdown menu for Stroke Style under Fill & Stroke tab

Asked by Benjamin Park on 2017-12-22

I am currently running Inkscape on Windows 10 Home 64-bit operating system, version 0.47. When I try to change the stroke style of a line I select, it won't show the dropdown menu for the different dash styles on the line. I think this may be a bug and that I need to update the software. I already tried uninstalling the programming and reinstalling it once. Help would be appreciated!

Question information

English Edit question
Inkscape Edit question
No assignee Edit question
Last query:
Last reply:
Hachmann (marenhachmann) said : #1

Uhm, yes. 0.47 is from 2009... That's 8 years old.

There is no support for that version anymore (and I don't remember any of its bugs).

The current version is 0.92.2 (from this summer), and it's available from here:

You should definitely update, unless you depend on some incompatible extensions working, which have not been updated since and where there exist no alternatives for you. Inkscape has made a huge leap since then!

A complete uninstall is necessary first.

Also, you might want to take a look into the various release notes from in between, you might discover some gems :)

Benjamin Park (bowling90) said : #2

Ok, so I have uninstalled the previous version and installed the latest version of Inkscape, and I still cannot seem to change the style of these lines that I have drawn using the pencil tool. I manage to get it to work once, but I can't seem to do it again. Help would be appreciated!

Hachmann (marenhachmann) said : #3

Please share the file and indicate which lines exhibit the issue.

Use a file hosting service for this (dropbox, google drive, framadrop, etc.) and share a link here in your next comment.

Benjamin Park (bowling90) said : #4

Here is the link to the file:

My trouble here is that I cannot seem to get the Dashes under the fill and stroke tab to let the dropdown menu to appear.
Any thoughts on how I could fix this would be appreciated!

Hachmann (marenhachmann) said : #5

The paths you have there have the path effect 'Power Stroke' applied to them, as you created them using the 'triangle in' or 'triangle out' option when you were using the pencil tool, probably.

Such paths, by default, do not have a stroke, because their fill acts as a stroke (to simulate a stroke of variable width, an object is created that has a fill that is wider or smaller in different places). Strokes are by definition always of the same width.

So, you can add a contour to your pencil 'lines', by adding a stroke in the stroke tab of the fill and stroke dialog. This will activate the stroke style dropdown. But it will draw an outline around the shape you created. It will not create a dashed line of variable width.

If you do not want the variable width, remove it by selecting the path, then doing Path -> Remove Path effects.
To not draw paths with that option, set the 'Shape' parameter of the pencil tool to 'None' in the tool controls bar right above the drawing area.

If you do indeed want a dashed line of variable width, there are ways to achieve that, but they are more complex, and I would suggest you open a discussion at for it.

Benjamin Park (bowling90) said : #6

How would I go about adding a stroke tab of the fill and stroke dialog?

Hachmann (marenhachmann) said : #7

Add a plain colored stroke by clicking on the first square in the 'stroke' tab of the 'fill and stroke' dialog.


Benjamin Park (bowling90) said : #8

Thank you!

On Jan 2, 2018 11:57 AM, "Hachmann" <email address hidden>

> Your question #662074 on Inkscape changed:
> Status: Open => Answered
> Hachmann proposed the following answer:
> Add a plain colored stroke by clicking on the first square in the
> 'stroke' tab of the 'fill and stroke' dialog.
> Screenshots:
> /the-fill-and-stroke-dialog/
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> confirm?answer_id=6
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> You received this question notification because you asked the question.

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.