svg output from lilypond - display is wrong

Asked by Gerard McConnell on 2012-12-15

Hello,
I'm trying to open SVG output from Lilypond in Inkscape 0.48 but it appears that it's not opening correctly.

I have put the SVG file and pictures (screen dumps?) of the .pdf output from Lilypond and the .svg display in Inkscape at:
https://www.dropbox.com/s/41vfg7hcz9s6cho/pdfOutput.JPG
https://www.dropbox.com/s/nukjkjfem7ys0v2/svgDisplay.JPG
https://www.dropbox.com/s/u0w9hmn5lxazjzp/guitarTwinkle.svg

The display is fine when I open the SVG file in Firefox.

Thanks very much for any help.
Gerard

Update:
I opened the SVG file in a text editor and replaced all occurrences of Century Schoolbook L with Times New Roman and the display is fine. The Century Schoolbook L font is in Inkscape's font drop-down menu, and it is in my machine's Font folder, so how come it appears that I can't use it in Inkscape? See this link:

https://www.dropbox.com/s/jtabz7y44o288px/fontProblem.JPG

Thanks again for any help,
Gerard

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Gerard McConnell
Solved:
2012-12-16
Last query:
2012-12-16
Last reply:
2012-12-16
su_v (suv-lp) said : #1

The SVG file renders just fine in Inkscape 0.48.2 and 0.48.3.1 on OS X 10.7.4.

There are two likely causes for your problem:
a) You don't have the font 'Century Schoolbook L' installed on your system (unlikely, because then the text would be rendered with the default font (Arial, on Windows)
or
b) If the font is installed, but renders no visible glyphs in Inkscape, you are likely affected by a known issue introduced with a recent security update for Windows (all versions) which broke certain types of fonts in many graphical applications (not only Inkscape is affected). Microsoft by now has acknowledged the issue:

«Known issues with this security update

    We are aware of issues related to OpenType Font (OTF) rendering in applications such as PowerPoint on affected versions of Windows that occur after this security update is applied. We are currently investigating these issues and will take appropriate action to address the known issues. »
<http://support.microsoft.com/kb/2753842>

See also:
<https://plus.google.com/108911244660285152681/posts/RV4qMPKFXkn>
<http://www.inkscapeforum.com/viewtopic.php?f=14&t=13232>

Additional links can be found in the comments to this question:
<https://answers.launchpad.net/inkscape/+question/216640>

su_v (suv-lp) said : #2

On 16/12/2012 22:31, Gerard McConnell wrote:
> Update: I opened the SVG file in a text editor and replaced all
> occurrences of Century Schoolbook L with Times New Roman and the
> display is fine. The Century Schoolbook L font is in Inkscape's
> font drop-down menu, and it is in my machine's Font folder, so how
> come it appears that I can't use it in Inkscape? See this link:
>
> https://www.dropbox.com/s/jtabz7y44o288px/fontProblem.JPG

See my earlier reply - this is the known issue with one of the latest
Windows security updates.

Gerard McConnell (gerrymcc) said : #3

Absolutely brilliant ~suv, Thanks very much :-)