Can't open eps file - ghostscript opens it ok

Asked by Dana on 2007-12-31

I can not open either .ai file or .eps file in inkscape of same image/file. Error message only says it can't open file. File is openable automatically if I double click on file on cd - it opens in ghostscript and I can save it to another location on my computer, but without changing file format.

I have tried to open file in gimp also and get error message:

"Error starting Ghostscript. Make sure that Ghostscript is installed and - if necessary - use the environment variable GS_PROG to tell GIMP about its location.
(Failed to execute child process (No such file or directory))". I have no idea what this means or how to solve this problem also.

Question information

Language:
English Edit question
Status:
Solved
For:
Inkscape Edit question
Assignee:
No assignee Edit question
Last query:
2008-01-09
Last reply:
2008-02-01
Bryce Harrington (bryce) said : #1

Which version of Inkscape are you using?

Note that Inkscape 0.45.1 and earlier can only open AI files from Illustrator version 7 and earlier. Only Inkscape 0.46+devel supports newer AI files.

Dana (dana10p) said : #2

Bryce,

  I wasn't clear about not being able to open eps files. Gimp says it can't find Ghostscript and therefore can't open the file. Error message says to program enviromentals and tell Gimp where to find it. GSview will open the eps file but can't do anything much with it of course.

  I tried to program enviromental variables in system control panel, but I may not be doing it right. I am using gs 8.61.

  Gimp error message reads:
        Error starting Ghostscript. Make sure that Ghostscript is installed and - if necessary - use the environment variable GS_PROG to tell GIMP about its location.
      (Failed to execute child process (Permission denied))

Bryce Harrington <email address hidden> wrote:
  Your question #21116 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/21116

Status: Open => Needs information

Bryce Harrington requested for more information:
Which version of Inkscape are you using?

Note that Inkscape 0.45.1 and earlier can only open AI files from
Illustrator version 7 and earlier. Only Inkscape 0.46+devel supports
newer AI files.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/inkscape/+question/21116

You received this question notification because you are a direct
subscriber of the question.

---------------------------------
Looking for last minute shopping deals? Find them fast with Yahoo! Search.

Bryce Harrington (bryce) said : #3

Which version of Inkscape are you using?

Dana (dana10p) said : #4

Bryce,

  In ref. to Inkscape: Inkscape 0.45.1, built Mar 21 2007.

  I don't get any type of error message. In Gimp, I get an error message saying it can't find ghostscript which is on my machine.

  Hope this helps.

  Thanks,
  Dana

Bryce Harrington <email address hidden> wrote:
  Your question #21116 on Inkscape changed:
https://answers.launchpad.net/inkscape/+question/21116

Status: Open => Needs information

Bryce Harrington requested for more information:
Which version of Inkscape are you using?

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/inkscape/+question/21116

You received this question notification because you are a direct
subscriber of the question.

---------------------------------
Looking for last minute shopping deals? Find them fast with Yahoo! Search.

Bryce Harrington (bryce) said : #5

Hi Dana,

Unfortunately, as I mentioned, you won't be able to open recent Illustrator files in Inkscape 0.45.1, because it doesn't support it. When Inkscape 0.46 is released, it will be able to do this. There is a pre-release alpha version of Inkscape 0.46 you could install and use if you really need the feature.

Regarding the problems with GIMP, unfortunately in this site we focus only on Inkscape problems. However, it sort of sounds like you have either the wrong version of Ghostscript, or have Ghostscript installed in an unexpected location. Sorry I can't help more with that issue.

Bryce

Bryce Harrington (bryce) said : #6

It's been some time since this question was answered, but as there hasn't been a response it's uncertain if your issue was successfully resolved. I'm marking it Solved, but if the issue still exists please do re-open it and explain where additional help is needed.

dbmdyxl (jliupku) said : #7

Hi Bryce,

My inkscape 0.45.1 cannot open/import eps files either, while my GIMP can open them.
When I try to open a EPS file, Inkscape says:

Inkscape has received additional data from the script executed. The script did not return an error, but this may indicate the results will not be as expected.
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
pstoedit: version 3.44 / DLL interface 108 (build Apr 29 2007 - release build - g++ 4.1.3 20070423 (prerelease) (Ubuntu 4.1.2-3ubuntu3)) : Copyright (C) 1993 - 2006 Wolfgang Glunz
Warning: colorimage with more than one datasrc not supported for this backend due to lack of support for images on raster files
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

and then I press ok, It says
"Failed to load the requested file xxxx.eps"

Thank you for your concern.

ambitious (jorge61579) said : #8

HI i have inkscape 0.46 and cannot open/import eps files either please help...

ink_user (lutz-dd) said : #9

I do have still the same issue using Inkscape (WinXP, Rel. 5.1.2600, Inkscape Rev 0.46, built April, 1st).
It returns the error message "Laden der gewünschten Datei ....\Desktop\Zeichnung.eps fehlgeschlagen" when using *.* filter

Neither OPEN or IMPORT can read the EPS file. The file is created by this inkscape release as trial.

pstoedit was installed before in the default directory C:\Programme\pstoedit
ghostscript was installed befine in the default directory C:\Programme\gs\gs8.61
GSview can read this eps file with no problems and it looks the same as in Inkscape.

ink_user (lutz-dd) said : #10

At the command line it can be converted to SVG by
C:\Programme\pstoedit\pstoedit.exe -f plot-svg Zeichnung.eps Zeichnung.svg
It looks the same except the page definition - but for EPS it's OK.

After that "pstoedit -f plot-svg" was modified to "C:\Programme\pstoedit\pstoedit.exe -f plot-svg"
in the file "C:\Programme\Inkscape\share\extensions\eps_input.inx" - restart - nothing has changed.

It seems the missing *.eps in the default filter "All Inkscape Files" for the FileOpen dialog indicate
a general missign link to the eps funktionality at read-/import.

ink_user (lutz-dd) said : #11

After adding "C:\Programme\pstoedit" to the"path" environment variable *.EPS is now available in the
file dialog for OPEN and IMPORT using default filter setting ("Inkscape files").

First forget to modifiy the change the file "eps_input.inx" and the tool crashed with "Runtime Error".
The header of the message box says "Microsoft Visual C++ Runtime Library"

Repair of the file "eps_input.inx" did not help. It still crashes with same error message.

It seems it's something outside "eps_input.inx".

I just want to say.. I have 0.46 and it doesn't load or import an eps file. :(
I will try the format conversion.

Luxuspunk (garbus) said : #13

Hey all...

Using 0.46 om OsX Tiger ... Having the same problems with .ai and .eps ... Tried the conversion from .eps to .svg, but still i get the error message: Failed to load the requestet file xxx.svg

Is the any way to get through this? Am really getting fond of all the other great stuff in inkscape... But without the import option, i cant really use it...

Hi

I can't import (or open) eps files in Inkscape. I'm using version 0.46.
I've done what the FAQ told me to do, Ghostscript is installed and ps2pdf is in my path.
My operative system is Ubuntu Intrepid Ibex.

Best regards, Hrafnkell