RPM installation of 3.21.4 fails on CentOS 7

Asked by Ross Palmer on 2021-06-03

I'm trying to install hplip 3.21.4 on CentOS 7 using the RHEL7 RPM. This fails:
# rpm -i hplip-3.21.4-RHEL7-x86_64.rpm
error: Failed dependencies:
 libImageProcessor.so()(64bit) is needed by hplipfull-3.21.4-0.x86_64
 libImageProcessor.so(VERS_1.0)(64bit) is needed by hplipfull-3.21.4-0.x86_64

However libImageProcessor.so is supplied by the hplip package itself so why is it listed as a dependency?

Installing using the .run file gives the same error.

As it happens the system has /usr/lib64/libImageProcessor.so()(VERS_1.0) present from
an earlier version of hplip but the dependency check doesn't pick that up.

So how can I get hplip 3.21.4 to install?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Ross Palmer
Solved:
Last query:
Last reply:
Revision history for this message
George Lenzer (glenzer2021) said (last edit ):
#1

Hi Ross. I was about to open the same question as I discovered the same thing. To get it to install, the following link works, but it does not allow for the use of 'yum' (which is preferred) since there is no --nodeps or --force option:

https://answers.launchpad.net/hplip/+question/674828

On a system where I had forced the installation of hplipfull-3.21.2 with the rpm command, I later tried to update with yum, and that failed even though the libImageProcessor.so file is already on the system:

root@server1:/root> ls -l /usr/lib64/libImageProcessor.so
lrwxrwxrwx 1 root root 38 Jun 2 15:28 /usr/lib64/libImageProcessor.so -> /usr/lib64/libImageProcessor-x86_64.so
root@server1:/root> ls -l /usr/lib64/libImageProcessor-x86_64.so
-rwxr-xr-x 1 root root 4646308 May 4 23:58 /usr/lib64/libImageProcessor-x86_64.so

Checking with rpm, the /usr/lib64/libImageProcessor-x86_64.so file is provided by hplipfull:

root@server1:/root> rpm -qif /usr/lib64/libImageProcessor-x86_64.so
Name : hplipfull
Version : 3.21.4
Release : 0
Architecture: x86_64
Install Date: Wed 02 Jun 2021 03:28:57 PM EDT
Group : Applications
Size : 31415390
License : (c) 2004-2009 Copyright HP Development Company, LP
Signature : (none)
Source RPM : hplipfull-3.21.4-0.src.rpm
Build Date : Wed 05 May 2021 12:00:27 AM EDT
Build Host : localhost
Relocations : (not relocatable)
Packager : <email address hidden>
Vendor : HP
Summary : HPLIP
Description :
The HP Linux Imaging and Printing (HPLIP) system
provides a unified single and multi-function connectivity
driver solution. HPLIPLITE provides support for print and scan only.
HPLIPFULL provides support for print, scan, fax and toolbox.

Please note, this is after I'd run the upgrade with 'rpm --force --nodeps -Uvh /path/to/rpm'. This behavior during the installation/upgrade via rpm and yum would seem to indicate some sort of circular dependency, or a pathing issue where the package manager is looking in the wrong place when checking dependencies. The /usr/lib64 location might be the issue if the package is checking /usr/lib, for example. This is just a guess on my part. Any insight from others on this?

Revision history for this message
Ross Palmer (dreamweaver54) said :
#2

Thanks George, the link you provided works though obviously it skips all the dependency checks (of which there are 50).
However my printer and scanner are working so fingers crossed its all OK.

From the link it seems this has been a known problem since at least 2018. Maybe it needs to be raised as bug rather than a question?