Problem found during HPLIP Installation on RedHat 7

Asked by Mark on 2018-10-08

I have downloaded the latest HPLIP package (3.18.9, rpm package) and tried to install on a Linux machine which is running RedHat Enterprise 7.5.

When I run through the command "rpm -i hplip-3.18.9_rhel-7.0.x86_64.rpm", it prompts that some of the dependencies are not found.
        libImageProcessor.so()(64bit) is hplipfull-3.18.9-0.x86_64 needed
        libImageProcessor.so(VERS_1.0)(64bit) is hplipfull-3.18.9-0.x86_64 is needed

Do you know how to obtain these dependencies and resolve this case?
Please note that the machine is in closed environment that is not allowed to connect to the public Internet. Glad if a complete offline package can be downloaded and install in individual machine.

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
srinivas
Solved:
2018-10-08
Last query:
2018-10-08
Last reply:
2018-10-08
Best srinivas (srinivas5) said : #1

Hi,

For RHEL 7, use the command "rpm -ivh --force --nodeps hplip-3.18.9_rhel-7.0.x86_64.rpm".

Regards,
Srinivas Teja.

Mark (markdelta1) said : #2

Thanks srinivas, that solved my question.