Problems with HP OfficeJet Pro 9012 on Debian 10.8

Asked by Claudia Neumann on 2021-03-08

I want to integrate the HP OfficeJet Pro 9012 in my office network. The hplip debian package doesn't recognize the OfficeJet. Installing the hplip-3.21.2.run is successful, but does not recognize the OfficeJet with error ipBus...

So I downloaded the Tarball, compiled und install on a Debian 10.8 successful. Now I can print and fax over the network. But I can not scan. Is that not possible?
hp-scan --device=<ip-address>

gives

error: <ip-address> device doesn't support this feature (or) Invalid device URI

What can I do?

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2021-03-09
Last reply:
2021-03-19
brian_p (claremont102) said : #1

Two things:

1. The hplip package in buster-backports supports you device.
2. https://wiki.debian.org/CUPSQuickPrintQueues

brian_p (claremont102) said : #2

3. buster-backports also has sane-airscan.

Hi,

installed hplip und hplip-gui.

hp-setup
error: Unable to locate models.dat file

HP Linux Imaging and Printing System (ver. 0.0.0)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to
accept the default.)

Using connection type: usb

error: No device selected/specified or that supports this functionality.

How do I get models.dat file?

CU

Claudia

Am Montag, 8. März 2021, 20:25:50 CET schrieb brian_p:
> Your question #695920 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/695920
>
> brian_p proposed the following answer:
> 3. buster-backports also has sane-airscan.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/hplip/+question/695920/+confirm?answer_id=1
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/hplip/+question/695920
>
> You received this question notification because you asked the question.

shivani mandora (shivani1708) said : #4

Hi ,

Please wait till we provide support for Debian 10.8.
It will be part of our next release.

Can you help with this problem?

Provide an answer of your own, or ask Claudia Neumann for more information if necessary.

To post a message you must log in.