Kububtu 20.04, HP 1109w, Proprietary plugin download hangs on "next"

Asked by John Egger on 2020-09-15

Summary line pretty much says it. I keep hopefully trying, but my test pages are piling up in the queue. I chose "download from an HP authorized server", clicked "next," and nothing further happens. On "Cancel," I'm told I chose to skip the plugin or entered an incorrect password. If the latter, I don't know where --- one was requested during the hplip installation; it was accepted and we proceeded from there.

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2020-09-17
Last reply:
2020-09-17
Manfred Hampl (m-hampl) said : #1

Try manually downloading the plugin installer in the version fitting to your HPLIP Installation from https://developers.hp.com/hp-linux-imaging-and-printing/plugins

John Egger (werdigo49) said : #2

Thank you, Manfred. I tried downloading the 3.20.6 plugin to my home page and installing it from there. I think I am in over my head here, though. Here are a few lines of the console output:

Enter the path to the 'hplip-3.20.6-plugin.run' file (q=quit) : /home/john/hplip-3.20.6-plugin.run

---------------
| COPY PLUGIN |
---------------

Downloading plug-in from: file:///home/john/hplip-3.20.6-plugin.run
Downloading plug-in: [\ ] 0% Traceback (most recent call last):
  File "/usr/share/hplip/base/password.py", line 85, in get_distro_name
    os_name = platform.dist()[0]
AttributeError: module 'platform' has no attribute 'dist'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/hp-plugin", line 363, in <module>
    status, plugin_path, error_str = pluginObj.download(plugin_path, plugin_download_callback)
  File "/usr/share/hplip/installer/pluginhandler.py", line 254, in download
    core = core_install.CoreInstall()
  File "/usr/share/hplip/installer/core_install.py", line 240, in __init__
    self.passwordObj = password.Password(ui_mode)

There is more but this may be enough to give you the idea. I have another system (using Kubuntu 16.04 and hplip 3.16) that works fine and maybe I should stick to that.

--- John
John B. Egger
Appalachian Trail journal: http://www.trailjournals.com/werdigo
Home page: http://www.johnbegger.com

> On 09/16/2020 3:20 AM Manfred Hampl <email address hidden> wrote:
>
>
> Your question #692933 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/692933
>
> Status: Open => Answered
>
> Manfred Hampl proposed the following answer:
> Try manually downloading the plugin installer in the version fitting to
> your HPLIP Installation from https://developers.hp.com/hp-linux-imaging-
> and-printing/plugins
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/hplip/+question/692933/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/hplip/+question/692933
>
> You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #3

There are known problems with Ubuntu 20.04 and the version of HPLIP from the HP pages.

I suggest that you uninstall everything and install the modified version of HPLIP from the Ubuntu repositories (version 3.20.3+dfsg0-2)

sudo apt install hplip-gui

Can you help with this problem?

Provide an answer of your own, or ask John Egger for more information if necessary.

To post a message you must log in.