Scanning Problem with Envy 5020

Asked by Derek Maxted on 2019-12-29

I am running Mint 19.2 on an old Acer Aspire 5733Z Pentium P6200, 2 GB DDR3 memory. No HD.
I'm away from home for three months and this is my travelling kit.
I failed to make HPLIP scan with a Hewlett Packard Laser printer (the cheap one) and swapped for an Envy 5020, which was on the 82 page supported printers list. For the history of this see:
https://answers.launchpad.net/hplip/+question/686420

The computer and HPLIP recognised the printer straight away and i had no problems with it.
However the scan items on the "Actions" menu of the HP Device manager failed to appear and I got an error message:
Device Communication Error 5012 - please correct

So I tried Simple Scan - which found the scanner and after a pause scanned successfully! HPLIP now found the scanner, the scan items came up on "Actions" and i was able to use the scanner for a while.

The "fix" is not reliable, sometimes I have to unplug and plug the scanner to get it to be recognised by simple scan, sometimes HPLIP will scan but not do a preview.
I suspect that the previous installations have confused things, although i did a system reset after the last issue was not solved, but i'm not certain how to start again or fix the issue..... please help me get this right.
The printer prints OK and photocopies.

Question information

Language:
English Edit question
Status:
Expired
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-12-31
Last reply:
2020-01-16
Derek Maxted (derekmax) said : #2

Sorry Last Post was meant to finish other question - ignor link!

brian_p (claremont102) said : #3

Is the device on USB or the network network?

--
Brian.

Derek Maxted (derekmax) said : #4

The device is linked directly by the usb cable, I am using a huawei modem for WiFi broadband on the second USB and running the PC on a memory stick on the third. All the computer peripherals work perfectly except the HD which is broken.

Derek Maxted (derekmax) said : #5

I tryed linking the scanner by wifi but it did not work

brian_p (claremont102) said : #6

It would be useful to see the outputs of 'lpstat -t' and 'lpinfo -v'.

--
Brian.

Derek Maxted (derekmax) said : #7

Hi Brian

derekmax@derekmax-Aspire-5733Z:~$ lpstat -t
scheduler is running
system default destination: ENVY-5000-series
device for ENVY-5000-series: hp:/usb/ENVY_5000_series?serial=TH97J9H0SK
device for Epson-Stylus-SX210: usb://EPSON/Stylus%20SX210?serial=4C41354B3036333154&interface=1
device for iP4600-series: usb://Canon/iP4600%20series?serial=108EC9
device for Stylus-TX100: usb://EPSON/Stylus%20TX100?serial=KQMZ001698&interface=1
ENVY-5000-series accepting requests since Sat 21 Dec 2019 08:05:07 AM GMT
Epson-Stylus-SX210 accepting requests since Fri 29 Nov 2019 05:46:00 PM GMT
iP4600-series accepting requests since Tue 19 Nov 2019 03:03:56 AM GMT
Stylus-TX100 accepting requests since Sat 16 Nov 2019 11:29:53 PM GMT
printer ENVY-5000-series is idle. enabled since Sat 21 Dec 2019 08:05:07 AM GMT
printer Epson-Stylus-SX210 is idle. enabled since Fri 29 Nov 2019 05:46:00 PM GMT
printer iP4600-series is idle. enabled since Tue 19 Nov 2019 03:03:56 AM GMT
printer Stylus-TX100 is idle. enabled since Sat 16 Nov 2019 11:29:53 PM GMT
derekmax@derekmax-Aspire-5733Z:~$

derekmax@derekmax-Aspire-5733Z:~$ lpinfo -v
file cups-brf:/
network https
direct hp
network ipp
network ipps
network beh
network lpd
network socket
network http
direct hpfax
derekmax@derekmax-Aspire-5733Z:~$

cheers
derek

Derek Maxted (derekmax) said : #8

BTW Happy new year!!!! :)

brian_p (claremont102) said : #9

Happy new year to you too, Derek.

'lpstat -t' shows

  hp:/usb/ENVY_5000_series?serial=TH97J9H0SK

This the URI for printing, which you have no trouble with. All well and good
up 'til now.

When it comes to scanning, HPLIP takes this URI and changes it to

  hpaio:/usb/ENVY_5000_series?serial=TH97J9H0SK

which is what its scanner program (libsane-hpaio) uses (or should use)
when you type 'simple-scan'. In other words, *automatic* sanner discovery.

You appear not to be getting this. Let us give the scanner URI directly to a
scanner program:

  scanimage -d hpaio:/usb/ENVY_5000_series?serial=TH97J9H0SK > image.pnm

Does that result in scanning?

The lpinfo -v' output is problematic. The "direct hp" line should have the hp:/usb/...
URI in it. There should also be a line with "direct usb" plus a URI.

--
Brian.

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.