After installing openSUSE Leap 15.1, I began to get filter failed

Asked by Keith Larter on 2019-11-19

I've reinstalled CUPS and HPLIP both from distribution database and HP developers portal.
The plug-in install consistantly fails and I cannot install any printers (they are networked) using CUPS, HP-SETUP or the openSUSE printer install. The printers are Envy 6255 and Colorlaserjet 2600n (with jet direct).

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-12-03
Last reply:
2019-11-21
brian_p (claremont102) said : #1

Follow the advice for plugin installation in Message #8 at at

https://answers.launchpad.net/hplip/+question/685574

Don't bother about anything else. Just do this.

What command did you use for plugin installation? What happened?

--
Brian.

Keith Larter (ezrapound) said : #2

Please find attached files.

filenames are self explanatory.

thanks,

kl

On 2019-11-19 8:13 p.m., brian_p wrote:
> Your question #686023 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/686023
>
> brian_p posted a new comment:
> Follow the advice for plugin installation in Message #8 at at
>
> https://answers.launchpad.net/hplip/+question/685574
>
> Don't bother about anything else. Just do this.
>
> What command did you use for plugin installation? What happened?
>
--
E. Keith Larter
42 Upper Meadowbank Rd
Meadowbank, PE
C0A 1H1
(902) 314-5225

This message (including attachments) may contain confidential or privileged information intended for a specific individual or organization.
If you have received this communication in error, please notify the sender immediately.
If you are not the intended recipient, you are not authorized to use, store, reproduce, or distribute any information contained in this email.

Created using Thunderbird email client on OpenSUSE

brian_p (claremont102) said : #3

Hello Keith,

> Please find attached files.

I read these mails on launchpad. I see no attached files or a way of getting them.

--
Brian.

brian_p (claremont102) said : #4

Ok, Keith, I'll assume the plugin is installed. Would you now give what
you get for 'lpinfo -v'.

--
Brian.

Keith Larter (ezrapound) said : #5

Not sure why the files didn't get to you.

My sent mail shows it went with 4 attachments.

Anyway here goes:

 lpinfo -v
network ipp
network ipps
network http
network socket
network https
network lpd
serial serial:/dev/ttyS0?baud=115200
direct hp
network beh
network smb
direct parallel:/dev/lp0
direct hpfax
network dnssd://HP%20Color%20LaserJet%202600n._pdl-datastream._tcp.local/
network
dnssd://HP%20ENVY%20Photo%206200%20series%20%5BFB54DE%5D._ipp._tcp.local/?uuid=dd1bfd0f-1c11-5a8d-cdf0-69be329e7734
network ipp://HP1062E5FB54DE.local:631/ipp/print

On 2019-11-20 3:17 p.m., brian_p wrote:
> Your question #686023 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/686023
>
> Status: Open => Needs information
>
> brian_p requested more information:
> Ok, Keith, I'll assume the plugin is installed. Would you now give what
> you get for 'lpinfo -v'.
>
--
E. Keith Larter
42 Upper Meadowbank Rd
Meadowbank, PE
C0A 1H1
(902) 314-5225

This message (including attachments) may contain confidential or privileged information intended for a specific individual or organization.
If you have received this communication in error, please notify the sender immediately.
If you are not the intended recipient, you are not authorized to use, store, reproduce, or distribute any information contained in this email.

Created using Thunderbird email client on OpenSUSE

brian_p (claremont102) said : #6

Let's do the Envy 6255 first. No plugin needed.

Its URI is

  ipp://HP1062E5FB54DE.local:631/ipp/print

Substitute in

  lpadmin -p envy6355 -v URI -E -m everywhere

Test with

  lp -d envy6355 /etc/nsswitch

--
Brian.

Keith Larter (ezrapound) said : #7

The Envy printer is now available to my computer. I would still like to get the laserjet working.
Many thanks.
kl

Keith Larter (ezrapound) said : #8

On the laserjet printer.
 I have configured it manually using Yast without hplip.
Seems to work fine as long as I don't set it to greyscale from an application (Libreoffice).
With greyscale set, I get the "filter error".
kl

Keith Larter (ezrapound) said : #9

 I don't know if it is connected, but since I replaced my black toner cartridge, I get "CUPS filter failed" when I try to print greyscale on my HP Color Laserjet 2600n.

Can the toner cartridge signal something to the printer which might trigger an error message. Seems to have started after I replaced the cartridge.

brian_p (claremont102) said : #10

> The Envy printer is now available to my computer.

Good.

Now for the 2600n. It requires a plugin for printing. I am unable to help with a toner
cartridge issue.

The URI from lpinfo -v is

  dnssd://HP%20Color%20LaserJet%202600n._pdl-datastream._tcp.local/

The PPD is

  drv:///hpcups.drv/hp-color_laserjet_2600n.ppd

Substitute in

  lpadmin -p 2600n -v URI -E -m PPD

Print with

  lp -d 2600n /etc/nsswitch

Any joy?

--
Brian.

brian_p (claremont102) said : #11

Typo. The file to print should be

/etc/nsswitch.conf

--
Brian.

Keith Larter (ezrapound) said : #12

I am beginning to suspect the toner cartridge. All works fine in colour mode.

Keith Larter (ezrapound) said : #13

On 2019-11-21 4:02 p.m., Keith Larter wrote:
> Your question #686023 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/686023
>
> Keith Larter posted a new comment:
> I am beginning to suspect the toner cartridge. All works fine in colour
> mode.
>
All works well on another openSUSE computer with earlier OS
I notice the driver is Color Laserjet 2600nijs 3.16.5

Keith Larter (ezrapound) said : #14

I have been able to simplify the problem.
1)With earlier versions of hplip there are no problems. (prior to my upgrade to current hplip and openSUSE.
 2)on current version I get "filter failed" when I try to print greyscale on the 2600n (colour works fine).

Can you help with this problem?

Provide an answer of your own, or ask Keith Larter for more information if necessary.

To post a message you must log in.