hplip not working in in Ubuntu 19.10

Asked by Keith Bates on 2019-11-02

Since I upgraded from 19.04 to 19.10 I have not been able to use my HP M1212.

I just installed hplip 3.19.10 but got the same result as 3.19.8. When it comes to running hp-setup I get this:

Traceback (most recent call last):
  File "/usr/bin/hp-setup", line 48, in <module>
    from base import device, utils, tui, models, module, services, os_utils
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    from . import status
  File "/usr/share/hplip/base/status.py", line 33, in <module>
    import cupsext
ImportError: libhpipp.so.0: failed to map segment from shared object

I have tried running the automatic install (including the remove and install option), running hplip as user and as root.

Thanks

Keith

Question information

Language:
English Edit question
Status:
Open
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-08
Last reply:
2019-11-08
shivani mandora (shivani1708) said : #1

Hi,

Can you please install 3.19.11 from hplip dev portal and check again.

Thanks,
Shivani

Hi Shivani,

I did that and still have the same result.

Thanks

Keith

On 8/11/19 4:58 pm, shivani mandora wrote:
> Your question #685567 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/685567
>
> Status: Open => Answered
>
> shivani mandora proposed the following answer:
> Hi,
>
> Can you please install 3.19.11 from hplip dev portal and check again.
>
>
> Thanks,
> Shivani
>
--
*Keith Bates**

**Senior Pastor

*p: 02 67924890

s: 4 Mooloobar St
     Narrabri, NSW 2390
w3w: checklist.windsurf.partly

e: <email address hidden> <mailto:<email address hidden>>

w: www.new-life.org.au <http://www.new-life.org.au>

*
*

why hplip-3.19.11 still don't support Ubuntu 19.10?

Can you help with this problem?

Provide an answer of your own, or ask Keith Bates for more information if necessary.

To post a message you must log in.