printer hp envy 5020 not working with ubuntu 18.04

Asked by jean-louis gueydon on 2018-10-04

after upgrading ubuntu 16.04 to ubuntu 18.04 my hp envy 5020 is no more working. The hp check on terminal says :
missing required dependencies : python3-pyqt4, gtk2-engines-pixbuf
missing optional dependencies : python3-notify2, python3-dbus.mainloop.qt

the problem is that i don't know how to add those dependencies ?

thanks in advance

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-05
Last reply:
2018-10-08
srinivas (srinivas5) said : #1

Hi,
Few of the required dependencies are still missing. You can install the latest hplip driver 3.18.9 which will install all the required packages for Ubuntu 18.04 in the installation process. Latest version can be downloaded from the portal: https://developers.hp.com/hp-linux-imaging-and-printing/gethplip

Thanks,
Srinivas Teja

jean-louis gueydon (jlgd) said : #2

Thank you Srinivas Teja

I have installed the latest hplip version - and the ufw firewall - but
it still doesn't work

hp doctor says that all the requested dependencies are installed, but
the device is not recognized. It says :

/error: PPD /etc/cups/ppd/.ppd file not found//
//warning:  is not HP Device.//
//warning: Fail to read ppd=/etc/cups/ppd/.ppd file//
//warning: Insufficient permission to access file /etc/cups/ppd/.ppd//
//warning: Could not complete Queue(s) configuration check//
/
and :

/Checking for HP Properitery Plugin's....//
//No plug-in printers are configured./

I am desperate !! Please tell me what to do, or if there is nothing to
do, what other printer would work with ubuntu 18.04

Thanks

Le 05/10/2018 à 06:47, srinivas a écrit :
> Your question #674684 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/674684
>
> Status: Open => Answered
>
> srinivas proposed the following answer:
> Hi,
> Few of the required dependencies are still missing. You can install the latest hplip driver 3.18.9 which will install all the required packages for Ubuntu 18.04 in the installation process. Latest version can be downloaded from the portal: https://developers.hp.com/hp-linux-imaging-and-printing/gethplip
>
> Thanks,
> Srinivas Teja
>

srinivas (srinivas5) said : #3

Hi,

Ubuntu 16.04 will have python 2 and HPLIP will install python 2 dependencies for HPLIP driver. When you upgrade to Ubuntu 18.04, it will have python 3 by default and python 3 HPLIP dependencies are not installed in the system. So you have to uninstall (hp-uninstall) and re-install HPLIP driver to install python 3 dependencies needed by the HPLIP driver.
Then do a hp-setup to add the device.
Hope it will fix the problem.

Regards,
Srinivas Teja.

Can you help with this problem?

Provide an answer of your own, or ask jean-louis gueydon for more information if necessary.

To post a message you must log in.