error code when running hp-setup

Asked by Bart Hollis on 2018-10-01

1. Your Linux Distribution and version: openSUSE Leap 15.0
2. Your printer make/model(s): pagewide 577dw, Officejet Pro 7720, OfficeJet Pro 8210 (Printers are working fine.)
3. If possible, run 'hp-check -t' and post the output:

bart@UNIVAC:~> hp-check -t
Saving output in log file: /home/bart/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.9)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile
HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to
successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
    OK
    MISSING - Missing Dependency or Permission or Plug-in
    INCOMPAT - Incompatible dependency-version or Plugin-version

warning: 0- version is not supported. Using 0-0 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 4.12.14-lp150.12.16-default #1 SMP Tue Aug 14 17:51:27 UTC 2018 (28574e6) GNU/Linux
 Host: UNIVAC
 Proc: 4.12.14-lp150.12.16-default #1 SMP Tue Aug 14 17:51:27 UTC 2018 (28574e6) GNU/Linux
 Distribution: 0
 Bitness: 64 bit

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.9
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 0 distro version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.17.9

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
ppdbase=/usr/share/cups/model/manufacturer-PPDs
doc=/usr/share/doc/packages/hplip
html==/usr/share/doc/packages/hplip
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/lib/cups/driver
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=no
cups-ppd-install=yes
internal-tag=3.17.9
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no

Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[fax]
email_address =
voice_phone =

[installation]
date_time = 10/01/18 12:14:15
version = 3.17.9

[last_used]
device_uri = "hp:/net/OfficeJet_Pro_7720_series?ip=192.168.3.27"
printer_name =
working_dir = .

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = false
rate = 30
type = 2

[settings]
systray_messages = 0
systray_visible = 0

[upgrade]
last_upgraded_time = 1518328405
latest_available_version = 3.17.10
notify_upgrade = true
pending_upgrade_time = 0

 <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.7 OK 'CUPS Scheduler is running'
 gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.23 OK -
 xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
 scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
 dbus DBus - Message bus system REQUIRED - 1.12.2 OK -
 policykit PolicyKit - Administrative policy framework OPTIONAL - 0.114 OK -
 network network -wget OPTIONAL - 1.19.5 OK -
 avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -

------------------------
| General Dependencies |
------------------------

 libjpeg libjpeg - JPEG library REQUIRED - - OK -
 cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.7 OK -
 cups-image CUPS image - CUPS image development files REQUIRED - 2.2.7 OK -
 libpthread libpthread - POSIX threads library REQUIRED - b'2.26' OK -
 libusb libusb - USB library REQUIRED - 1.0 OK -
 sane SANE - Scanning library REQUIRED - 1.0.27 OK -
 sane-devel SANE - Scanning library development files REQUIRED - 1.0.27 OK -
 libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
 libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.0 OK -
 python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.5 OK -
 python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'
 python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
 python3-xml Python XML libraries REQUIRED - 2.2.5 OK -
 error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.5 MISSING 'python3-devel needs to be installed'
 error: python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - - MISSING 'python3-pil needs to be installed'
 error: python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 - MISSING 'python3-reportlab needs to be installed'

--------------
| COMPILEDEP |
--------------

 libtool libtool - Library building support services REQUIRED - 2.4.6 OK -
 gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.3.1 OK -
 make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.2.1 OK -

---------------------
| Python Extentions |
---------------------

 cupsext CUPS-Extension REQUIRED - 3.17.9 OK -
 hpmudext IO-Extension REQUIRED - 3.17.9 OK -

----------------------
| Scan Configuration |
----------------------

 hpaio HPLIP-SANE-Backend REQUIRED - 3.17.9 OK 'hpaio found in /etc/sane.d/dll.conf'
 scanext Scan-SANE-Extension REQUIRED - 3.17.9 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/OfficeJet_Pro_7720_series?ip=192.168.3.27' is a Hewlett-Packard OfficeJet_Pro_7720_series all-in-one
device `brother4:net1;dev0' is a Brother MFC-J875DW MFC-J875DW

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

HP-577
------
Type: Unknown
Device URI: dnssd://HP-577._pdl-datastream._tcp.local/?uuid=7e6b0b29-9768-5fa6-9428-41c5bdec51da
PPD: /etc/cups/ppd/HP-577.ppd
warning: Failed to read /etc/cups/ppd/HP-577.ppd ppd file
PPD Description:
Printer status: printer HP-577 is idle. enabled since Sun 30 Sep 2018 05:08:20 PM MDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

HP-7720
-------
Type: Printer
Device URI: hp:/net/OfficeJet_Pro_7720_series?ip=192.168.3.27
PPD: /etc/cups/ppd/HP-7720.ppd
PPD Description: HP Officejet Pro 7720 Series, hpcups 3.17.11
Printer status: printer HP-7720 is idle. enabled since Sun 30 Sep 2018 01:51:35 PM MDT
Communication status: Good

MFCJ875DW
---------
Type: Unknown
Device URI: dnssd://Brother%20MFC-J875DW._ipp._tcp.local/
PPD: /etc/cups/ppd/MFCJ875DW.ppd
PPD Description: Brother MFC-J875DW CUPS
Printer status: printer MFCJ875DW is idle. enabled since Sun 01 Apr 2018 07:19:10 PM MDT
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

--------------
| PERMISSION |
--------------

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None

Total Errors: 5
Total Warnings: 2

Done.

4. A detailed explanation of your problem: When I run hp-setup I get an error message that says: error: libglib-2.0.so.0: failed to map segment from shared object. The prompt is returned.

5. Steps to recreate the problem:
 open a command prompt
type hp-setup

I have a laptop that is running the same version of Linux and it is working correctly. I checked and it does not have python3-devel installed. I installed it on this machine anyway and there was no change.

I am relatively sure there is a conflict somewhere. I decided to explore Python development a while ago, and installed some packages. Since, I cannot setup my printers using hp-setup, only directly by cups as shown in the output from hp-check. I could live with that but I can't set up the scanner on the 577. I need hp-setup!

Question information

Language:
English Edit question
Status:
Answered
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-04
Last reply:
2018-10-04
Badal (badalkumar) said : #1

Hi,

Opensuse Leap 15 is not a supported distro version by the HPLIP driver.
So hp-check is having some errors due to failed HPLIP dependency packages.
So please use suse 13.2 or suse 42.3 supported distro versions to install HPLIP driver properly without any errors.
The you will not see any issues with hp-setup.

Thanks,
Badal Kumar.

Bart Hollis (bart.hollis) said : #2

Certainly you jest!

Am I to understand that you recommend I install a version of Linux that
has no security updates? Do you actually consider this an acceptable
response? Because I don't!

13.2 has passed EOL quite some time ago! It isn't even available in
the normal places!

I'm going to stop typing now. I am trying so hard to be civil! I
purchased a very expensive printer based on the information provided by
HP that Linux is supported. And this is the support provided?

Do NOT close this ticket! I am not satisfied!

Bart Hollis!

On Wed, 2018-10-03 at 07:22 +0000, Badal wrote:
> Your question #674581 on HPLIP changed:
> https://answers.launchpad.net/hplip/+question/674581
>
> Status: Open => Answered
>
> Badal proposed the following answer:
> Hi,
>
> Opensuse Leap 15 is not a supported distro version by the HPLIP
> driver.
> So hp-check is having some errors due to failed HPLIP dependency
> packages.
> So please use suse 13.2 or suse 42.3 supported distro versions to
> install HPLIP driver properly without any errors.
> The you will not see any issues with hp-setup.
>
> Thanks,
> Badal Kumar.
>

srinivas (srinivas5) said : #3

Hi,
Opensuse Leap 15 support to be enabled in hplip will be discussed with team and we will update the plan. 42.3 version is available which has all security updates available. Until the version 15 support is enabled in hplip the version 42.3 can be used for printer setup and use. We will keep this ticket in open state until we update the plan for supporting the latest version 15.

Can you help with this problem?

Provide an answer of your own, or ask Bart Hollis for more information if necessary.

To post a message you must log in.