Cannot generate print jobs due to missing foomatic-rip-hplip

Asked by Ryan Novosielski on 2008-03-30

I've installed Ubuntu Hardy on my laptop and have not been able to print in the same way that I was on Gutsy. First of all, for whatever reason, none of the foomatic drivers will show up in KDE's printer manager for some reason. I remember I had to deal with this in Gutsy at some point as well, though I believe the fix was to run kbuildsycoca, which has not worked for Hardy. At any rate, I have no idea whether or not this is related to my ultimate problem. Either case, it ought to work and doesn't.

Anyways, I manually select the proper PPD file in order to get around its not showing in the list. I attempt to print something and see the following in my logs:

E [29/Mar/2008:20:31:57 -0400] Unable to execute /usr/lib/cups/filter/foomatic-rip-hplip: No such file or directory
E [29/Mar/2008:20:31:57 -0400] [Job 16] Unable to start filter "foomatic-rip-hplip" - No such file or directory.

True enough, this filter does not exist. However, I can't see anything I've done wrong to cause it not to exist. In addition, there's no package I could install that would contain it. On top of that, Gutsy did not appear to have it either. Can anyone throw me a bone here? :)

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
HPLIP Edit question
Assignee:
No assignee Edit question
Solved by:
Ryan Novosielski
Solved:
2008-04-03
Last query:
2008-04-03
Last reply:
2008-03-31

Hey Ryan,

Please run hp-check -t and post the output.

Thanks!

Aaron

Ryan Novosielski (novosirj) said : #2

Heh... ;) Well, that's an easy one:

root@novosirj-laptop:~# hp-check -t
bash: hp-check: command not found

I don't know what else I could install though:

root@novosirj-laptop:~# dpkg -l | grep hp
ii foomatic-db-hpijs 20070813-0ubuntu2
           OpenPrinting printer support - database for
ii hpijs 2.8.2+2.8.2-0ubuntu4
           HP Linux Printing and Imaging - gs IJS drive
ii hpijs-ppds 2.8.2+2.8.2-0ubuntu4
           HP Linux Printing and Imaging - HPIJS PPD fi
ii hplip 2.8.2-0ubuntu4
           HP Linux Printing and Imaging System (HPLIP)
ii hplip-data 2.8.2-0ubuntu4
           HP Linux Printing and Imaging - data files
ii hplip-gui 2.8.2-0ubuntu4
           HP Linux Printing and Imaging - GUI utilitie

Okay that just means you are using the pre-installed hplip. If possible try installing the latest hplip from source and see if you have different results.

The automatic installer works well with gutsy so you shouldn't experience any difficulty.

Let me know if you have any problems/or it doesn't help resolve the problem.

A

Ryan Novosielski (novosirj) said : #4

I don't really consider that to be an answer, but I guess it is a workaround. I'm told a patch will be released for this as it is already fixed in Debian SVN.

Ryan,

I can understand your response. The distros can and do make changes to hplip prior to installing it and including it in the distro package. Although we try to be as involved as possible the distros make the choices as to what works best for them and their users on what parts of hplip to include and/or change. So I guess my point is this seems to be a problem with the pre-packaged hplip and not the hplip from source which indicates this is a problem with the something the distro is doing.

I know this doesn't help resolve your problem, and if this is going to be fixed in debian it will probably be fixed in ubuntu as well.

All the best,

Aaron

Ryan Novosielski (novosirj) said : #6

I'm told this was fixed:

This bug was fixed in the package hplip - 2.8.2-0ubuntu6

---------------
hplip (2.8.2-0ubuntu6) hardy; urgency=low

  * debian/control: Let hpijs depend on foomatic-filters (LP: #187403).
  * debian/control, debian/hplip.links: Added missing links to utilities
    hp-check and hp-scan. Added dependency on python-imaging for hp-scan.
  * debian/rules: Corrected filter name from "foomatic-rip-hplip" to
    "foomatic-rip" (LP: #211382).
  * debian/hplip.preinst: Remove obsolete /etc/default/hplip file before
    installation of the hplip binary package (LP: #211377).

 -- Till Kamppeter <email address hidden> Thu, 3 Apr 2008
22:28:52 +0200

** Changed in: hplip (Ubuntu)
       Status: Fix Committed => Fix Released

---

Thanks for the time spent answering this.

josephbus1 (josephbus1) said : #7

Remove HPLIP 3.10.2, restoring previous version