Unable to import new uploaded model

Asked by Safa Naseem on 2017-05-04

Dear HEPMDB Team,

I have uploaded the model files for a CalcHEP model, but when I try and import the model on the Calculate page, it is not displayed in the list of models on the left, despite showing a message that the model is being imported. Kindly help me understand how to properly upload/import the model.

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
HEPMDB Edit question
Assignee:
No assignee Edit question
Solved by:
Alexander Belyaev
Solved:
2017-05-05
Last query:
2017-05-05
Last reply:
2017-05-05

Dear Safa,

thanks for reporting the problem and sorry for the delay with my reply.
There could be several reasons for this problem.

For example, the problem can be related to how did you packed (tar, zip etc) your model
If you like you can send me (<email address hidden>) your model in exact form as you uploaded it
 so I can reproduce the problem and solve it

You can also try to "Reset Account" using "Menu" in the top right corner of the "Calculate" session
and repeat your action in case if something went wrong.

Regards,
Alexander

Safa Naseem (safa-paki) said : #2

Dear Alexander,

Thanks for addressing my problem. I did as you said: deleted the model I had uploaded, reset my account, and then re - uploaded the model files, but still with the same result.

I also considered using different extensions for my packed model folder, but to no avail, the result is the same.

I have emailed you the packed folder containing the model files, just as they were uploaded; it would be a great help if you could look at them and let me know what's wrong.

Thank you.

Regards,
Safa

Dan Locke (danl0) said : #3

Hi Safa,

I took a look at the file you sent to Alexander and it seems you are trying to use a .tar.gz rather than a .tar. I converted the file and tested and it seems to work fine.

Regards
Dan

Dan Locke (danl0) said : #4

Hi Safa,

I see that this is a different format to what is suggested, I will look into it and get back to you.

Regards
Dan

Dan Locke (danl0) said : #5

Hi Safa,

I unpacked your model and rezipped to .tar, .tar.gz and .tgz and all worked correctly for me. How did you create your .tar.gz? The filesize on your file appears to be larger than the ones I created. Please try zipping using 'tar -czvf' if possible.

Regards,
Dan

Hi Dan,

Safa has tgzipped the whole folder -- that was the reason of the problem.
He did this correctly though.
I believe we need to add the option of importing the model from the folder also
or think about how clearly tell users what they can upload

So, Safa, at the moment, please do not tgz the folder -- just the model files themselves

Regards,

Alexander

Safa Naseem (safa-paki) said : #7

Hello Dan,

Thank you for your answer and suggestions.
I had previously used the same command you mentioned to compress my folder. In any case, I compressed it again in all three formats, and uploaded them. But when I try to import the model, in all three cases, the result is the same: a message, confirming that the model is being uploaded, is displayed; but after that the name of the model does not appear in the list on the left in the "Calculate" session.

Regards,
Safa

Safa Naseem (safa-paki) said : #8

Thank you for your response Alexander.

Now I understand what the problem was, but could you please give more explicit instructions as to how I should upload the .mdl files? Because when using the browse feature to upload the model, I can only select one file/folder, which would mean that I need to zip the entire folder to upload all the files of the model.

Regards,
Safa

Dan Locke (danl0) said : #9

Hi Safa

Yes, I appreciate it can be a little confusing. I will add more information to the pop-up in order to avoid similar user problems in future.

Thanks,
Dan

Hi Safa

there are several options how you can gzip or tar model files correctly, avoiding zipping the whole folder
(this is at the moment, soon we will fix this, so the zipped folder will also work)

1. from the command line in shell, suppose the folder where you have your model called KNTDilepton

cd KNTDilepton
tar -cvf model.tar *.mdl

this will create model.tar which you can upload
or

cd KNTDilepton
tar -zcvf model.tar.gz *.mdl

which will create model.tar which you can upload

2. using icon and mouse

a) double clic (or one click, depending on your settings) to KNTDilepton folder
b) select all files there with the mouse
b) compress them to .tar or .tar.gz file

this is it

After 1) or 2) you should be able to upload successfully files to HEPMDB

Hi Dan,
could you add the option with the folder or clear description what can
be uploaded?
There were several problems like this in the past, I simply forgotten
about this

Cheers,
Sasha

On 05/05/17 13:04, Alexander Belyaev wrote:
> Question #631106 on HEPMDB changed:
> https://answers.launchpad.net/hepmdb/+question/631106
>
> Alexander Belyaev proposed the following answer:
> Hi Dan,
>
> Safa has tgzipped the whole folder -- that was the reason of the problem.
> He did this correctly though.
> I believe we need to add the option of importing the model from the folder also
> or think about how clearly tell users what they can upload
>
> So, Safa, at the moment, please do not tgz the folder -- just the model
> files themselves
>
> Regards,
>
> Alexander
>

--
Prof. Alexander S Belyaev (<email address hidden>)
http://www.hep.phys.soton.ac.uk/~belyaev/

School of Physics & Astronomy, University of Southampton, Office: 5047
SO17 1BJ, TEL.: +44 (0)23 8059 8509; FAX.: +44 (0)23 8059 3910
.....................................................................
Particle Physics Department, Rutherford Appleton Laboratory, Didcot,
OX11 0QX, TEL.: +44 (0)1235 445562; FAX.: +44 (0)1235 446733
.....................................................................
CERN: Office: 40 1-B20 Mailbox: E27910; ccid: 532076
TEL: +41 22 76 71642
______________________________________________________________________

Safa Naseem (safa-paki) said : #12

Thank you very much for your detailed answer on how to correctly tar the model files.
I was able to figure out what I was doing wrong and uploaded the model files again.
However, now it is taking quite long to import the model.
Once it is imported, I will mark this question as solved.

Regards,
Safa

Dan Locke (danl0) said : #13

Hi Safa

It should not take very long to upload the files (a few seconds). I will email you a version of the model zip that worked for me.

Regards
Dan

Safa Naseem (safa-paki) said : #14

Hi everyone,

Thanks for the email, Dan. I've been able to successfully import the model files you sent, and it's working perfectly.
Thank you all for helping me solve this problem.

Safa Naseem (safa-paki) said : #15

Thanks Alexander Belyaev, that solved my question.