ufw firewall is off by default and my attempts to set it to activate at startup have failed.

Asked by Glenn Turner on 2012-09-13

Hello. I recently installed Linux Mint 13 MATE. I found that the ufw firewall is inactive by default. I would like to have it activated with the computer startup, but although I have been able to acitvate the firewall after a startup, using sudo ufw enable, or the gui, I have not properly set it up so that it activates at startup. Each time I boot up the computer the firewall is inactive. Thank you for any suggestions.

Question information

Language:
English Edit question
Status:
Solved
For:
Gufw Edit question
Assignee:
No assignee Edit question
Solved by:
Glenn Turner
Solved:
2012-09-16
Last query:
2012-09-16
Last reply:
2012-09-16
costales (costales) said : #1

Hi! :) Could you give us this command exit, just when the computer startup:
sudo ufw status
Thanks in advance!

Glenn Turner (gturner) said : #2

Thank you for taking your time to help.

Here is the command exit:

glenn@glenn-Vostro-220-Series ~/Desktop $ sudo ufw status
[sudo] password for glenn:
Status: inactive
glenn@glenn-Vostro-220-Series ~/Desktop $

Thanks again.

Glenn Turner

costales (costales) said : #3

And these exits?
sudo ufw enable
sudo ufw status
Reboot
sudo ufw status
 On Sep 13, 2012 8:31 PM, "Glenn Turner" <
<email address hidden>> wrote:

> Question #208427 on Gufw changed:
> https://answers.launchpad.net/gui-ufw/+question/208427
>
> Status: Answered => Open
>
> Glenn Turner is still having a problem:
> Thank you for taking your time to help.
>
> Here is the command exit:
>
> glenn@glenn-Vostro-220-Series ~/Desktop $ sudo ufw status
> [sudo] password for glenn:
> Status: inactive
> glenn@glenn-Vostro-220-Series ~/Desktop $
>
> Thanks again.
>
> Glenn Turner
>
> --
> You received this question notification because you are a member of Gufw
> Developers, which is an answer contact for Gufw.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~gufw-developers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~gufw-developers
> More help : https://help.launchpad.net/ListHelp
>

Glenn Turner (gturner) said : #4

Thank you,

The exits after typing sudo ufw enable and sudo ufw status were:

glenn@glenn-Vostro-220-Series ~/Desktop $ sudo ufw enable
[sudo] password for glenn:
Firewall is active and enabled on system startup
glenn@glenn-Vostro-220-Series ~/Desktop $ sudo ufw status
Status: active

To Action From
-- ------ ----
51413/tcp DENY Anywhere
51413/udp DENY Anywhere
51413/tcp DENY Anywhere (v6)
51413/udp DENY Anywhere (v6)

51413/tcp ALLOW OUT Anywhere
51413/udp ALLOW OUT Anywhere
51413/tcp ALLOW OUT Anywhere (v6)
51413/udp ALLOW OUT Anywhere (v6)
glenn@glenn-Vostro-220-Series ~/Desktop $

And after rebooting:

glenn@glenn-Vostro-220-Series ~ $ sudo ufw status
[sudo] password for glenn:
Status: inactive
glenn@glenn-Vostro-220-Series ~ $

costales (costales) said : #5

I think you have a problem with ufw.
Could you try to reinstall? Just run this command:
sudo apt-get purge ufw ; sudo apt-get install ufw
And repeat the comment #3
Thanks in advance! :)
---
Costales.

On Thu, Sep 13, 2012 at 11:11 PM, Glenn Turner
<email address hidden> wrote:
> Question #208427 on Gufw changed:
> https://answers.launchpad.net/gui-ufw/+question/208427
>
> Status: Answered => Open
>
> Glenn Turner is still having a problem:
> Thank you,
>
> The exits after typing sudo ufw enable and sudo ufw status were:
>
> glenn@glenn-Vostro-220-Series ~/Desktop $ sudo ufw enable
> [sudo] password for glenn:
> Firewall is active and enabled on system startup
> glenn@glenn-Vostro-220-Series ~/Desktop $ sudo ufw status
> Status: active
>
> To Action From
> -- ------ ----
> 51413/tcp DENY Anywhere
> 51413/udp DENY Anywhere
> 51413/tcp DENY Anywhere (v6)
> 51413/udp DENY Anywhere (v6)
>
> 51413/tcp ALLOW OUT Anywhere
> 51413/udp ALLOW OUT Anywhere
> 51413/tcp ALLOW OUT Anywhere (v6)
> 51413/udp ALLOW OUT Anywhere (v6)
> glenn@glenn-Vostro-220-Series ~/Desktop $
>
>
> And after rebooting:
>
>
> glenn@glenn-Vostro-220-Series ~ $ sudo ufw status
> [sudo] password for glenn:
> Status: inactive
> glenn@glenn-Vostro-220-Series ~ $
>
> You received this question notification because you are a member of Gufw
> Developers, which is an answer contact for Gufw.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~gufw-developers
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~gufw-developers
> More help : https://help.launchpad.net/ListHelp

Glenn Turner (gturner) said : #6

Hello,

I purged ufw and then reinstalled ufw, rebooted and checked the ufw status with the command sudo ufw status. It still comes up as status inactive after rebooting.

Thank you again for your time.

costales (costales) said : #7

Just a few people have this problem in the last year :( but I can't reproduce it, then my help is very limited :( I'm sorry!
This appears be an ufw bug.
@Jamie Strandboge: Any idea, please? Thanks in advance!

Glenn Turner (gturner) said : #8

Thank you for spending your time trying to help me. I will try reinstalling Linux Mint. Perhaps that will fix it.

costales (costales) said : #9

@Glen You're welcome! :)
That could be the fast way :P Please, give us the result :)
Thanks and good luck!