Highlighted Color Does Not Appear

Asked by archp2008 on 2014-05-04

I have Grub Customizer 4 installed on Linux Mint 15. I have tried various backgound images successfully (all 1400x1050). Also the font size and color for the normal text works perfectly. The only thing is the highlighted color. I have white/black for normal text and yellow/black for highlighted. This shows correctly in the preview window with the top meu item being yellow text instead of white like the rest, but when I reboot the text remains white including the selected item. Is there a know cause for this problem? Thanks in advance for any comments.

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Richter
Solved:
2014-06-06
Last query:
2014-06-06
Last reply:
2014-06-05
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Sorry for the late answer.

Linux mint places an image at /boot/grub. This is usually preferred by the 05_debian_theme and prevents the usage of your selected background image and colors. So you should remove any images placed at /boot/grub.

archp2008 (archwparsons) said : #3

Hi,

Thanks for the reply. This is not a major issue so no problem with
the late answer. Actually, I cannot find an image in /boot/grub or any
of the subfolders of the grub folder. The picture I am using is a
371 gb jpeg image saved at home/arch/pictures.

Regards,

Arch Parsons

On 14-05-22 05:02 PM, Daniel Richter wrote:
> Your question #248149 on Grub Customizer changed:
> https://answers.launchpad.net/grub-customizer/+question/248149
>
> Status: Expired => Answered
>
> Daniel Richter changed the question status:
> Sorry for the late answer.
>
> Linux mint places an image at /boot/grub. This is usually preferred by
> the 05_debian_theme and prevents the usage of your selected background
> image and colors. So you should remove any images placed at /boot/grub.
>

The problem is the script /etc/grub.d/06_mint_theme which overwrites the settings (at least the colors) which have been set by 05_debian_theme before. The 06_mint_theme has its own config. If this config doesn't exist (as in your case) then the default colors (gray/white) are written to the final grub.cfg.

It's odd that mint has its own configuration here :-(

You can fix it either by deleting the /etc/grub.d/06_mint_theme on command line or you can disable it by grub customizer (this allows you the restore it easily):

1) show placeholders by clicking view -> "show placeholders"
2) select the "(script code)" entry of the script "mint_theme" and click the remove button

archp2008 (archwparsons) said : #5

The Grub highligh color is working however an error window just popped up saying, "unable to load Mate screenshot," or words to that effect. I don't know if that message will keep popping up or not.

archp2008 (archwparsons) said : #6

I rebooted and that message did not come back. There was another message prior to the deletion of the script code saying that its deletion may cause problems with booting. Evidently this message can be ignored. Thank you very much for resolving this issue for me.