wallpaper image kills the splash image.

Asked by smurf on 2013-02-01

Hi, I'm using Grub Customizer 3.04 on Ubuntu 12.04.
With the appearence configuration I selected a jpg image as Grub wallpaper, it works fine, but when the kernel is started the image stay on the screen and I can't see my splash image, actually the splash appears only at the last 2 or 3 seconds of the boot.
It could be possible to make disappear the wallpaper image once the kernel has been manually or automatically selected?
Thx a lot.

Question information

Language:
English Edit question
Status:
Solved
For:
Grub Customizer Edit question
Assignee:
No assignee Edit question
Solved by:
smurf
Solved:
2013-02-04
Last query:
2013-02-04
Last reply:

Sorry, I don't have a solution here.

Grub Customizer just sets the image by using the standard way (adding GRUB_MENU_PICTURE to /etc/default/grub) and placing a script at /usr/share/desktop-base/grub_background.sh which sets the correct properties). It doesn't change something regarding the boot behaviour. Also I don't think this is configurable.

smurf (luca-dgh) said : #2

I understand, i'll just try to ask to the grub developpers.
Thx a lot Daniel.

smurf (luca-dgh) said : #3

Just for your info I reprt here what they answered me on Grub mailing list.

> Hi to all.
> I'm using Ubuntu 12.04 (AMD64) with Grub2. I customized the grub appearence
> using the Grub Customizer software (by Daniel Richter) and everything is ok,
> but I found that using a jpg image as wallpaper, that image stay on the
> screen after the kernel has been choose (manually or automatically) and this

This is actually an Ubuntu "feature", they wanted to have a seamless
transition between grub, plymouth, and GDM and so they configured
things so that the image left by grub doesn't get overwritten until
plymouth starts. This feature seems to be configured by passing the
vt.handoff=7 kernel parameter and is technically outside the scope of
grub as it's not grub that's interpreting this parameter but I'll try
to pass on what (little) information I know about it (most of which
can be found at
http://askubuntu.com/questions/32999/what-is-vt-handoff-7-parameter-in-grub-cfg
as well).

> kills the splash image.

VT handoff should not "kill the splash image", if by "splash image"
you mean plymouth, and I don't think that it is interfering with
plymouth in your case. If you're not seeing plymouth at boot then
that's probably a separate problem, and if it weren't for vt.handoff=7
you'd probably just see a black screen until *DM instead of seeing the
image that grub left.

> As Daniel says in this Launchpad answer
> https://answers.launchpad.net/grub-customizer/+question/220803 , his
> software uses the standard way to set the wallpaper image.
> So my question is:
> There is something we can do to make disappear the wallpaper image once the
> kernel has been selected to start?

Removing vt.handoff=7 will probably accomplish this, though as stated
above what you probably really want is to get plymouth working,

> Or is a "bug" that must be corrected in the grub2 code?

It's a feature implemented with cooperation between grub and the
kernel (and userspace utilities during the boot process) which you're
noticing because plymouth isn't taking over early in the boot process
as it should for some reason.

> Thx a lot.

You're welcome.

-- Jordan Uggla (Jordan_U on irc.freenode.net)

Thank you!