Can't install GnoMenu on Fedora 13 64Bit

Asked by Hans Meier on 2010-08-03

Good morning,

I solved most issues. Just one thing: If I try to use the KDE widget for GnoMenu it crashes - if I run it manually, e.g. via /usr/bin/GnoMenu.py run-in-tray, it works.

Does anybody know how to make the KDE widget work?

Thanks in advance.

Best regards,
Shunyata

Question information

Language:
English Edit question
Status:
Solved
For:
GnoMenu Edit question
Assignee:
No assignee Edit question
Solved by:
Hans Meier
Solved:
2010-08-04
Last query:
2010-08-04
Last reply:
2010-08-04
technoshaun (shaun-marolf) said : #1

Try /usr/bin/GnoMenu.py run-in-window from a terminal to see if that crashes, if so send us the output.

Nope. After my changes it works just fine:

gconf backend
GnoMenu 2.9
settings load
gmenu found, using it as default menu parser
map
start
shaping window
show
focus lost
hide
cleanup

But if I now choose the GnoMenu widget by Helder Fraga Plasma gets an Aborted Signal and accordingly goes down.

I started this thread since I experienced problems in getting GnoMenu to run on a 64Bit system. Maybe I should consult Fraga directly? Or do you happen to know a solution?

Thanks in advance.

Best regards,
Shunyata

technoshaun (shaun-marolf) said : #3

On Wed, 2010-08-04 at 02:22 +0000, Hans Meier wrote:
> Question #119788 on GnoMenu changed:
> https://answers.launchpad.net/gnomenu/+question/119788
>
> Hans Meier posted a new comment:
> Nope. After my changes it works just fine:
>
> gconf backend
> GnoMenu 2.9
> settings load
> gmenu found, using it as default menu parser
> map
> start
> shaping window
> show
> focus lost
> hide
> cleanup
>
> But if I now choose the GnoMenu widget by Helder Fraga Plasma gets an
> Aborted Signal and accordingly goes down.
>
> I started this thread since I experienced problems in getting GnoMenu to
> run on a 64Bit system. Maybe I should consult Fraga directly? Or do you
> happen to know a solution?
>
> Thanks in advance.
>
>
> Best regards,
> Shunyata
>
Helder is on a unscheduled hiatus, unfortunately, can you send the
plasma error?

I don't know why, but it suddenly works. I can't close Firefox anymore (click on x button is ignored), but it works. I'll observe it over the next days, but since I'm an optimist I consider it solved.

Unfortunately, the dump wasn't very informative. The only relevant part seemed as said that Plasma got an Aborted signal every time I started the widget.

Whether somebody fixed it or I just had luck: Thank you ^^

Best regards,
Shunyata