How to stop ever-growing backup volume?

Asked by GilgongoJones on 2017-03-30

I'm using duplicity 0.7.11 on Ubuntu and have a nightly backup script that does a 'remove-older-than 10D --force' before a '--full-if-older-than 5D' to a backup volume over rsync.

The trouble is that the backup volume never reduces in size.

What am I doing wrong?

Question information

Language:
English Edit question
Status:
Answered
For:
Duplicity Edit question
Assignee:
No assignee Edit question
Last query:
2017-04-02
Last reply:
2017-04-09
edso (ed.so) said : #1

On 30.03.2017 13:48, GilgongoJones wrote:
> New question #601449 on Duplicity:
> https://answers.launchpad.net/duplicity/+question/601449
>
> I'm using duplicity 0.7.11 on Ubuntu and have a nightly backup script that does a 'remove-older-than 10D --force' before a '--full-if-older-than 5D' to a backup volume over rsync.
>
> The trouble is that the backup volume never reduces in size.
>
> What am I doing wrong?
>

can you send a collection-status? ..ede/duply.net

GilgongoJones (gilgongo) said : #2

Thanks - this is what I get with that (although I recently had to delete the volume, cache and run the backup from scratch).

BTW why does it also always say "Last full backup date: none"?

Local and Remote metadata are synchronized, no sync needed.
Last full backup date: none
Collection Status
-----------------
Connecting with backend: BackendWrapper
Archive directory: /home/gilgongo/.cache/duplicity/02be6e629f6ff2159271c8f6cd84ce8d

Found 0 secondary backup chains.
No backup chains with active signatures found
No orphaned or incomplete backup sets found.

edso (ed.so) said : #3

On 01.04.2017 08:33, GilgongoJones wrote:
> Question #601449 on Duplicity changed:
> https://answers.launchpad.net/duplicity/+question/601449
>
> Status: Answered => Open
>
> GilgongoJones is still having a problem:
> Thanks - this is what I get with that (although I recently had to delete
> the volume, cache and run the backup from scratch).
>
> BTW why does it also always say "Last full backup date: none"?
>
> Local and Remote metadata are synchronized, no sync needed.
> Last full backup date: none
> Collection Status
> -----------------
> Connecting with backend: BackendWrapper
> Archive directory: /home/gilgongo/.cache/duplicity/02be6e629f6ff2159271c8f6cd84ce8d
>
> Found 0 secondary backup chains.
> No backup chains with active signatures found
> No orphaned or incomplete backup sets found.
>

duplicity does not seem to see any files on your backend. can you make sure that there is at least one duplicity chain there?

using rsync backend can usually be replaced with sftp:// or pexpect+sftp:// . maybe it is a backend issue on your side.

..ede/duply.net

GilgongoJones (gilgongo) said : #4

Thanks. If I list the content of the volume on the file system, I get:

duplicity-full.20170330T101056Z.manifest.gpg
duplicity-full.20170330T101056Z.vol1.difftar.gpg
duplicity-full-signatures.20170330T101056Z.sigtar.gpg
duplicity-inc.20170330T101056Z.to.20170331T041800Z.manifest.gpg
duplicity-inc.20170330T101056Z.to.20170331T041800Z.vol1.difftar.gpg
duplicity-inc.20170331T041800Z.to.20170401T041302Z.manifest.gpg
duplicity-inc.20170331T041800Z.to.20170401T041302Z.vol1.difftar.gpg
duplicity-inc.20170401T041302Z.to.20170402T041359Z.manifest.gpg
duplicity-inc.20170401T041302Z.to.20170402T041359Z.vol1.difftar.gpg
duplicity-new-signatures.20170330T101056Z.to.20170331T041800Z.sigtar.gpg
duplicity-new-signatures.20170331T041800Z.to.20170401T041302Z.sigtar.gpg
duplicity-new-signatures.20170401T041302Z.to.20170402T041359Z.sigtar.gpg

The server I'm pushing the backup to is running and rsync server, with the following in /etc/rsyncd.cnof:

[bkp-alice]
     path = /home/bkp/server
     hosts allow = x.x.x.57 2001:x::x:x:::39
     hosts allow = x.x.x.uk
     read only = false
     uid = root

Using SSH would require key validation. Can the duplicity SSH backend do that? SSH password auth isn't enabled.

GilgongoJones (gilgongo) said : #5

I tried sftp:// and got:

BackendException: could not load ~/.ssh/known_hosts, maybe corrupt?

Then tried pexpect+sftp:// and got:

Attempt 1 failed. AttributeError: 'NoneType' object has no attribute 'encode'
Attempt 2 failed. AttributeError: 'NoneType' object has no attribute 'encode'
Attempt 3 failed. AttributeError: 'NoneType' object has no attribute 'encode'

edso (ed.so) said : #6

On 02.04.2017 22:43, GilgongoJones wrote:
> Using SSH would require key validation. Can the duplicity SSH backend do
> that? SSH password auth isn't enabled.

yes you may use the parameter --ssh-options "-oIdentityFile=/my/backup/id" as documented in
  http://duplicity.nongnu.org/duplicity.1.html

or use ~/.ssh/config to setup auth for the target host for the user running the backup.

you may wanna read the manpage, we have two ssh backends (paramiko [default] & pexpect [legacy]).

..ede/duply.net

edso (ed.so) said : #7

On 03.04.2017 00:03, GilgongoJones wrote:
> Question #601449 on Duplicity changed:
> https://answers.launchpad.net/duplicity/+question/601449
>
> GilgongoJones gave more information on the question:
> I tried sftp:// and got:
>
> BackendException: could not load ~/.ssh/known_hosts, maybe corrupt?
>
> Then tried pexpect+sftp:// and got:
>
> Attempt 1 failed. AttributeError: 'NoneType' object has no attribute 'encode'
> Attempt 2 failed. AttributeError: 'NoneType' object has no attribute 'encode'
> Attempt 3 failed. AttributeError: 'NoneType' object has no attribute 'encode'
>

that sounds like a very old duplicity. please upgrade to the latest stable 0.7.12 ..ede/duply.net

GilgongoJones (gilgongo) said : #8

Thanks - but the version in question is 0.7.12 (I'm using the duplicity-team PPA on Ubuntu 14.4)

I'll see if I can get a dedicated SSH password-auth account set up for the backup user and see if that works.

edso (ed.so) said : #9

On 07.04.2017 09:27, GilgongoJones wrote:
> Question #601449 on Duplicity changed:
> https://answers.launchpad.net/duplicity/+question/601449
>
> GilgongoJones posted a new comment:
> Thanks - but the version in question is 0.7.12 (I'm using the duplicity-
> team PPA on Ubuntu 14.4)
>
> I'll see if I can get a dedicated SSH password-auth account set up for
> the backup user and see if that works.
>

make sure that duplicity see's your first full (will be listed in the terminal output) in order for incremental backups to work.

..ede/duply.net

Can you help with this problem?

Provide an answer of your own, or ask GilgongoJones for more information if necessary.

To post a message you must log in.