Boost library was not found on Mac snowleopard

Asked by Sungick Kim on 2010-06-17

Dorsal installation was successful. However, I have a new problem running a demo.py file.
Boost 1.42.0 is installed through Macports, and header files and libraries are in the default position.
( '/opt/local/include/boost' and '/opt/local/lib')
Any ideas?

sungick:python sungick$ python demo.py
Warning: Converting real-valued parameter to double, might loose precision.
Calling FFC just-in-time (JIT) compiler, this may take some time.
Traceback (most recent call last):
  File "demo.py", line 23, in <module>
    Q = FunctionSpace(mesh, "CG", 1)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/dolfin/function/functionspace.py", line 226, in __init__
    FunctionSpaceBase.__init__(self, mesh, element)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/dolfin/function/functionspace.py", line 44, in __init__
    ufc_element, ufc_dofmap = jit(self._ufl_element)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/dolfin/compilemodules/jit.py", line 44, in mpi_jit
    return local_jit(*args, **kwargs)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/dolfin/compilemodules/jit.py", line 103, in jit
    return jit_compile(form, parameters=p, common_cell=common_cell)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/ffc/jitcompiler.py", line 56, in jit
    return jit_element(object, parameters)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/ffc/jitcompiler.py", line 135, in jit_element
    (compiled_form, module, form_data) = jit_form(form, parameters)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/ffc/jitcompiler.py", line 107, in jit_form
    cache_dir = cache_dir)
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/ufc_utils/build.py", line 53, in build_ufc_module
    (cpp_path, swig_path) = configure_instant()
  File "/Users/sungickkim/Work/FEniCS/lib/python2.6/site-packages/ufc_utils/build.py", line 122, in configure_instant
    """
OSError: The Boost library was not found.
If Boost is installed in a nonstandard location,
set the environment variable BOOST_DIR.

Question information

Language:
English Edit question
Status:
Solved
For:
DOLFIN Edit question
Assignee:
No assignee Edit question
Solved by:
Harish Narayanan
Solved:
2010-06-17
Last query:
2010-06-17
Last reply:
2010-06-17
Best Harish Narayanan (hnarayanan) said : #1

Following the last line :), make sure you set the BOOST_DIR variable.

export BOOST_DIR=/opt/local/include

Harish Narayanan (hnarayanan) said : #2

And Johannes, could you change the default lookup path on darwin to the path I suggested above?

Johannes Ring (johannr) said : #3

Yes, but it should be /opt/local not /opt/local/include, right?

Harish Narayanan (hnarayanan) said : #4

On 6/17/10 8:34 AM, Johannes Ring wrote:
> Question #114861 on DOLFIN changed:
> https://answers.launchpad.net/dolfin/+question/114861
>
> Johannes Ring posted a new comment:
> Yes, but it should be /opt/local not /opt/local/include, right?
>

Actually, I just realised it works with dolfin-dev without setting the
variable. So I'd suggest just leaving it, and Sungick setting it by hand
for this version.

Harish

Sungick Kim (sungick) said : #5

Thanks Harish Narayanan, that solved my question.