network manager keeps asking WEP key

Asked by BVP on 2009-01-03

Hi. I got my mini 9 with preinstalled ubuntu 8.04.1 by Dell. My wifi system was working without too much trouble until this afternoon. I was away for a couple of hours, and then I found the connection was dropped. So, I tried to reconnect it, but then I never could.
It asked me to enter WEP key, and I typed the correct key. But after a minute or so, it asked again, in fact, forever, without connecting to the internet. I can see the list of possible wireless networks around here by clicking the left button, but I cannot connect to the net.
After reading some postings, I tried disable System->Hardware Drivers->wl and reboot it;
then I enabled the driver again, but the problem still persists.
The only thing I change this afternoon after I came back to the machine was to change the root password. But I don't think that has anything to do with the wifi, right?

Thanks for your help!
BVP

Question information

Language:
English Edit question
Status:
Solved
For:
The Dell Mini Project Edit question
Assignee:
No assignee Edit question
Solved by:
BVP
Solved:
2009-01-04
Last query:
2009-01-04
Last reply:
2009-01-03
Fabián Rodríguez (magicfab) said : #1

Why would you change or enable the root password ? Could you describe how you did that ? It's possible the password was saved in a previously available keyring which became unavailable when you made that change. In order to reproduce that I'd need to know how you did that change.

Could you also provide a reference to the wl driver reloading ?

The root account is not enabled (and doesn't need to be) in Ubuntu for several reasons.

If you're using WEP encryption you may want to switch to WPA as WEP is trivial to break and you network may be compromised easily.

BVP (bvp) said : #2

Dear Fabian,

Thank you for your help!
But, all of sudden, it started working again. The only reason I can think of is the following.
Yesterday, my son's friend came to our house with her laptop while I was away. She connected her laptop to our wireless router. This reached the maximum number of connected computers at home (I'm using comcast). While I was writing my posting, she was here and using her laptop. After posting it and after she left, all of sudden, it accepted the WEP key and it connected to the internet.

As for the root password, I wanted to become root to do certain things rather than prepending "sudo" all the time. So, what I did was: go to System->Administration->Users and Groups; select root; and set up my favorite password. Then I can do "su" and become the root using that password. Apparently, however, this change of password had nothing to do with the wireless problem I had.

I hoped that the comcast router could issue some more diagnostic messages rather than kicking me out from connections...

Best regards,
BVP

anjilslaire (anjilslaire) said : #3

Add another wireless router to the comcast via ethernet, disable wireless on the comcast hardware and connect wirelessly to your new router.
The comcast will see 1 device (the new router), and all of your PC's will be NAT'ed by your own router, providing as many (up to 255) connections as you want/need.

BVP (bvp) said : #4

Hi, anjilslaire.

Thank you for your information. In fact, last Thursday, a comcast technician came to our house to replace the older combined cable modem + wireless router (linksys) by a separate set of a cable model and a new wireless router (netgear). Since then, I haven't had any connection problem at all! I should have called them and asked them to replace it sooner. They said that the monthly fee stays the same as before.

Best,
BVP

lencast (lencast) said : #5

I have all the connections right, but the mini will not accept the password. Tried manual, still will not connect. It discovers the network, but won't connect. Please help.

BVP (bvp) said : #6

Dear lencast,

As my previous posts suggest, my problem was the wireless router I initially got from comcast. It simply didn't accept more than 5 devices connected to the router simultaneously. After changing this to a new one, I didn't have any wireless connection problem because now the limit is 256 devices (or 128 devices, I forgot the exact number).
Have you checked if your router is connected to the maximum number of devices already?
If not, it should work. Other than that, I really cannot give any further advice.
Maybe other experts such as Fabian can help you...

Best regards,
BVP

Béné (bene-d) said : #7

lencast,

Am I right in assuming we are dealing with a WEP password here? In that case you might have to select the right password type, e.g. WEP HEX-key or WEP-ASCI (that's not the exact wording, but it's something like that).
You can find these options in the drop-down menu under the field where you enter your password. If you don't know whether your password is in HEX or ASCI (HEX is lots of gobbled letters and number, ASCI often a real word) just try each.

Good luck!
Béné

lencast (lencast) said : #8

Bene,

I have tried the HEX and ASCii, and continue unsucceful. The password is a phone number with ten numbers, and with the "enable networking" and " enable wireless" both highlighted, it won't accept the password for the network I want to connect. I am so disgusted with this UBUNTU op. system, that I am about to send the computer back. If you have any other ideas, I would be most grateful.

Lena (lencast)

---- "Béné" <email address hidden> wrote:
> Question #56210 on The Dell Mini Project changed:
> https://answers.launchpad.net/dell-mini/+question/56210
>
> Béné posted a new comment:
> lencast,
>
> Am I right in assuming we are dealing with a WEP password here? In that case you might have to select the right password type, e.g. WEP HEX-key or WEP-ASCI (that's not the exact wording, but it's something like that).
> You can find these options in the drop-down menu under the field where you enter your password. If you don't know whether your password is in HEX or ASCI (HEX is lots of gobbled letters and number, ASCI often a real word) just try each.
>
> Good luck!
> Béné
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

--
Lena

Béné (bene-d) said : #9

Lena,

I am really sorry this is not working out for you, usually connecting to a wireless network shouldn't be a problem for Ubuntu.
 So, you tried selecting the different WEP encryption methods and it still won't connect. I assume it doesn't give you an error message, right?
Have you ever had the chance to try whether you can connect to other wireless networks? If that worked, the router you are trying to connect to might be the problem. Can you give us the name of the model?

Best,
Béné

Béné (bene-d) said : #10

Oh, one more thing. Have you read this: https://help.ubuntu.com/community/DellMini9#Connecting%20to%20a%20wireless%20router
Maybe that is of any help to you.

lencast (lencast) said : #11

Dear Bene,

Thank you so much for responding to my plight... I was able to connect to my wireless at home after having a similar problem, and aslso to a non security network. Now here at my daughter's house, I have been having this problem again, but unable to solve the problem this time and unable to connect to her network. She has a Lynksis router Wireless N Broadband, model # WRT160N. The mini finds the network, asks for the security passkey, and then after a few minutes the window pops up again, asking the same. I have read the instructions on your other email link, and other than the driver thing (I am afraid to do that), I have followed everything else. What stumps me is the fact, that I see the appropriate highlighted wireless phrases in the network icon, and it still does not accept the network passkey.

Thanks for your help. The Ubuntu community, is the best as it always comes to the rescue...

Lena

---- "Béné" <email address hidden> wrote:
> Question #56210 on The Dell Mini Project changed:
> https://answers.launchpad.net/dell-mini/+question/56210
>
> Béné posted a new comment:
> Lena,
>
> I am really sorry this is not working out for you, usually connecting to a wireless network shouldn't be a problem for Ubuntu.
> So, you tried selecting the different WEP encryption methods and it still won't connect. I assume it doesn't give you an error message, right?
> Have you ever had the chance to try whether you can connect to other wireless networks? If that worked, the router you are trying to connect to might be the problem. Can you give us the name of the model?
>
> Best,
> Béné
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

--
Lena