Sorry, this hub does not allow clients sending buggy $Supports command Problem

Asked by lokutus on 2011-11-16

hi,

i got a connection prob :

"Sorry, this hub does not allow clients sending buggy $Supports command."

the hub is a Ptokax in a LAN. the forum of the hub says, the client (dc++) is the problem.
now i, got to know how to fix it . i tried the settings, but nothing works.

someone an idea ?

de++ client 0.782 (actuall, i think)
winxp sp3
no other connection probs.
btw. sending buggy $suport commands can use as a DDos attack against the hub so i have to fix it.

regards,

lokutus

Question information

Language:
English Edit question
Status:
Expired
For:
DC++ Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-19
Last reply:
2011-12-05
eMTee (realprogger) said : #1

eMTee suggests the last section of this article as an answer to your question:
FAQ #83: “I've just upgraded to the newest version of DC++. Now I can't connect / search / download. What happened?”.

Big Muscle (bigmuscle) said : #2

The main problem that this hubsoft is developed by retarded person who neither knows what definition of "bug" is.

lokutus (lokutus25) said : #3

ok, thx for the information. hm, what hub sofware can be recommended and works fast and secure with this client ?
(winxp 32bit plattform , only LAN connections)
Unfortunately I could not find reasonable software by google (for example).

regards

lokutus

eMTee (realprogger) said : #4

Every maintained hub software should work with DC++ if its well configuread and that kind of retard settings like the one in your case are disabled.

eMTee (realprogger) said : #5

A bit outdated but still useful list of available DC hubsoftware : http://www.dslreports.com/faq/6545

Mutor (mjtosques) said : #6

Is all the negative energy necessary?
wouldn't it be even easier to just remove the blank?
Per your own documentation

http://neisep.com/dc/index.php?title=$Supports

• A blank $Supports is not permitted

lokutus (lokutus25) said : #7

"Mutor : Is all the negative energy necessary?"

erm, why negative energy ?
just asking a simple question. btw. i read some about the "blank" $Supports but i can´t find a thing about
deaktivating or change the blanks.

the hub log isn´t a good help (no specific "blank" field is named).
icould it be change per the "Expert" settings ?

a little bit more information could be helpful. sry, i didn´t worked with this software so much.

thanks,

regards

lokutus

Mutor (mjtosques) said : #8

By negative I was referring to others calling people retarded.

At any rate the $Supports format is wrong in some way.
In PtokaX [you never mentioned which version or platform]
GUI -> Users/Chat, tick CMDs and then connect with the
'offending client'. Then you can see what the client sent.

Moreover this is an optional. Settings -> More General
So you may allow poorly formatted $Supports or not.

Big Muscle (bigmuscle) said : #9

But the reason is not anything poorly formatted. DC++ sends $Support in the format "$Support f1 f2 f3 |". Notice the space character between f3 and |. It does not break anything, it is there for ages (probably since the time when $Support command was introduced) and it always worked with all hubsofts correcty. No problem... so why the option to block such clients was added? We all know the reason ;-)

Launchpad Janitor (janitor) said : #10

This question was expired because it remained in the 'Open' state without activity for the last 15 days.