Bazaar Version Control System

mkdir error with push to launchpad

Asked by Pascal Wolkotte on 2008-02-15

I am trying to upload my files to a new Launchpad project using:

bzr push lp:~p-t-wolkotte/pgfgraph/trunk

I receive the following error, but I have not found an answer to this problem.

I lp:~p-t-wolkotte/pgfgraph/trunk is redirected to http://bazaar.launchpad.net/~p-t-wolkotte/pgfgraph/trunk/
bzr: ERROR: Cannot lock LockDir(http://bazaar.launchpad.net/%7Ep-t-wolkotte/pgfgraph/trunk/.bzr/branch/lock): Transport operation not possible: http does not support mkdir()

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Pascal Wolkotte
Solved:
2008-02-17
Last query:
2008-02-17
Last reply:
2008-02-16
Martin Albisetti (beuno) said : #1

Have you set your user name with: "bzr launchpad-login username"?

This will use bzr+ssh instead of http which cannot do write operations (push)

Pascal Wolkotte (p-t-wolkotte) said : #2

Thank you. That solved the problem.

Dustin Kirkland  (kirkland) said : #3

It would be nice if bzr's error message "http does not support mkdir()" would suggest that the user needs to "bzr launchpad-login username".

:-Dustin

Martin Albisetti (beuno) said : #4

Newer versions of bzr actually do this. Thanks for the suggestion.

Ashish Bhatia (asb-tiny) said : #5

i am still not able to commit thru windows

Wouter van Heyst (larstiq) said : #6

On Thu, Nov 20, 2008 at 11:10:51AM -0000, AshishSingh Bhatia wrote:
> Question #24695 on Bazaar changed:
> https://answers.launchpad.net/bzr/+question/24695
>
> AshishSingh Bhatia posted a new comment:
> i am still not able to commit thru windows

If you have the same problem as Pascal Wolkotte had, what is not clear
from Martin's answer?

If you do not have the same problem, please file a seperate question.

Wouter

ThomasRutter (trr) said : #7

I had this problem recently in 2.0.4

"bzr launchpad-login trr" was not enough to fix it.

I had to do a "bzr launchpad-login trr" and then also a "bzr bind lp:~trr/projectname/branchname" to fix it.

What had happened is that when I had previously checked out a branch from launchpad, it set up my local branch as being bound to an http address of launchpad instead of bzr+ssh.

So when I did launchpad-login it didn't change the bind address as that had already been set.

Anyway, hope this helps someone.

Shah Japan (jsh.axelor) said : #8

can anyone tell me what ths solution for following error,
I'm not able to revert using bzr

bzr: ERROR: Cannot lock LockDir(http://bazaar.launchpad.net/~openerp/openobject-client-web/5.0/.bzr/branch/lock): Transport operation not possible: http does not
support mkdir()

E:\tiny\stable\web>bzr version
Bazaar (bzr) 2.1.0
  Python interpreter: C:\Python26\python.exe 2.6.4
  Python standard library: C:\Python26\lib
  Platform: Windows-post2008Server-6.1.7600
  bzrlib: C:\Python26\lib\site-packages\bzrlib
  Bazaar configuration: C:\Users\japan\AppData\Roaming\bazaar\2.0
  Bazaar log file: C:\Users\japan\Documents\.bzr.log

Copyright 2005, 2006, 2007, 2008, 2009 Canonical Ltd.
http://bazaar-vcs.org/

bzr comes with ABSOLUTELY NO WARRANTY. bzr is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 2 or later.

Bazaar is part of the GNU Project to produce a free operating system.

Jelmer Vernooij (jelmer) said : #9

jsh.axelor, you need to tell Bazaar about your Launchpad login so that it will try to access Launchpad using bzr+ssh rather than over http (the latter does not support writes). You can tell Bazaar about your login using:

$ bzr lp-login <username>

Leo Arias (elopio) said : #10

I got the same error.
I tried bzr lp-login and bzr bind and neither of those worked.

I manually edited the file .bzr/branch/branch.conf and changed the push_location to use bzr+ssh instead of http and it worked.

Denero Team (deneroteam) said : #11

Thanks Leo,

I am getting same problem of Transport operation not possible: http does not support mkdir()

I follow as following and is worked.

-- bzr launchpad-login <username>
-- open .bzr/branch/branch.conf and changed push_location url from http to bzr+ssh

Thanks,
Dhaval Patel
Denero Team

Vincent Ladeuil (vila) said : #12

> open .bzr/branch/branch.conf and changed push_location url from http to bzr+ssh

bzr push --remember <bzr+ssh url> would have the same effect and doesn't require hand-editing.

Roel Van de Paar (roel11) said : #13

Sometimes you may get this particular error if you branched using a different username (for example: root) then the one you're trying to push with etc.

Simply re-branch in a new/fresh directory using your own username (I usually mv <origdir> <origdir.old> then bzr branch)

Roel Van de Paar (roel11) said : #14

Hmm, I wonder if #13 was the real cause for the issue I was seeing. I tried bzr push lp:parent, which did not work. However, bzr push lp:real_project_name worked fine. In any case, executing items in #13 may help as well if you're using different user names.