boot-sav depends on glade2script (>= 3.2)

Asked by Maurice McCarthy on 2012-12-05

The version of glade2script on launchpad seems to be out of date.

I'm running LinuxMint 13 64 bit. And I have precise-backports in sources.list
Tried to install boot-repair. Downloaded debs for glade2script, boot-sav, boot-repair and did

# dpkg -i glade2script_3.0.5-1_all.deb
# dpkg -i boot-sav_3.193.7-1_all.deb boot-repair_3.193.7-1_all.deb

But this error was reported:
dpkg: dependency problems prevent configuration of boot-sav:
 boot-sav depends on glade2script (>= 3.2) | glade2script-gtk2; however:
  Version of glade2script on system is 3.0.5-1.
  Package glade2script-gtk2 is not installed.
dpkg: error processing boot-sav (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of boot-repair:
 boot-repair depends on boot-sav (>= 3.193); however:
  Package boot-sav is not configured yet.
dpkg: error processing boot-repair (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Errors were encountered while processing:
 boot-sav
 boot-repair

Many Thanks for all the hard work btw
Maurice McCarthy

Question information

Language:
English Edit question
Status:
Solved
For:
Boot-Repair Edit question
Assignee:
No assignee Edit question
Solved by:
YannUbuntu
Solved:
2012-12-06
Last query:
2012-12-06
Last reply:
2012-12-05
Best YannUbuntu (yannubuntu) said : #1

thanks for the feedback.
I will fix this next time I update the DEBs in Launchpad.

As an alternative, i recommend you download the DEBs from the PPA ( https://launchpad.net/~yannubuntu/+archive/boot-repair/+packages )

Maurice McCarthy (manselton) said : #2

Thanks YannUbuntu, that solved my question.

Maurice McCarthy (manselton) said : #3

Ahh, I thought there ought to be a ppa around! I'm a silver surfer -
forgetful and not always too clued up on these things.

Many Thanks for the reply
Maurice

On Wed, Dec 05, 2012 at 09:45:57PM -0000, YannUbuntu wrote:
> Your question #216021 on Boot-Repair changed:
> https://answers.launchpad.net/boot-repair/+question/216021
>
> Status: Open => Answered
>
> YannUbuntu proposed the following answer:
> thanks for the feedback.
> I will fix this next time I update the DEBs in Launchpad.
>
> As an alternative, i recommend you download the DEBs from the PPA (
> https://launchpad.net/~yannubuntu/+archive/boot-repair/+packages )
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/boot-repair/+question/216021/+confirm?answer_id=0
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/boot-repair/+question/216021
>
> You received this question notification because you asked the question.

--
You will lose your present job and have to become a door to door mayonnaise
salesman.

Dan (petersdj) said : #4

I used the DEB packages from the link that Yann provided but I still get the same error that Maurice posted (an error about the version of boot-sav). I installed the boot-sav and boot-sav-extra packages and then ran boot-repair and get the error. Any suggestiong?

Thanks!

Dan (petersdj) said : #5

Here's the error from running it in the terminal:

Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 boot-repair : Depends: boot-sav (>= 3.196) but 3.196~ppa3~precise is to be installed
               Recommends: pastebinit but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Here's the error using GDebi:

Error: Dependency is not satisfiable: boot-sav (>= 3.196)

Maurice McCarthy (manselton) said : #7

Dan

I hope this grandad is not teaching granny to suck eggs but did you
add the ppa repository? That was the mistake I made - of course you
would still have had the same error until it was fixed.

sudo add-apt-repoitory ppa:/~yannubuntu/boot-repair

but that line in from a failing memory!

Regards
Maurice

On 16/12/2012, Dan <email address hidden> wrote:
> Your question #216021 on Boot-Repair changed:
> https://answers.launchpad.net/boot-repair/+question/216021
>
> Dan posted a new comment:
> Here's the error from running it in the terminal:
>
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
> boot-repair : Depends: boot-sav (>= 3.196) but 3.196~ppa3~precise is to be
> installed
> Recommends: pastebinit but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
>
>
> Here's the error using GDebi:
>
> Error: Dependency is not satisfiable: boot-sav (>= 3.196)
>
> --
> You received this question notification because you asked the question.
>