start time ignored, other instructions followed

Asked by raydar on 2014-01-06

Audio Recorder seems to ignore the start time argument for me. I click the "Save" button, and have the "Timer" checkbox checked, but whether I set the start time for 30 seconds or several hours in the future, no audio file is ever created, no audio is recorded.

If I manually use the "Start Recording" button, however, it records just fine and heeds the instructions that come *after* start time (stop after x minutes, for example, works).

Could something about my system be keeping Audio Recorder unaware of the time? I'm running Ubuntu Studio 13.10, using its standard low-latency kernel, and I've configured the system to display 24-hour time but haven't changed anything else relevant that I can think of.

Question information

Language:
English Edit question
Status:
Solved
For:
Audio Recorder Edit question
Assignee:
No assignee Edit question
Solved by:
moma
Solved:
2014-01-21
Last query:
2014-01-21
Last reply:
2014-01-16

This question was reopened

  • 2014-01-16 by moma
moma (osmoma) said : #1

Hello,
Would you please copy&paste the timer commands here. I will then figure out how to debug the timer module.

raydar (raydar) said : #2

Sure; this is the current state of it, with a few of the different start & stop commands I've tried up to now, all but one commented out. Notably, the very first line is commented out at this time, but it's behaved the same even when the first line was not a commented line.

#start at 20:58:00
start at 19:28:00
stop at 23:02
#stop after 2h 35min
#stop after 3h
#stop after 1min
# stop if silence 4s 20%
#stop if silence | 100MB
#start if voice 0.3
#start if voice 30%

raydar (raydar) said : #3

Oh good grief, I accidentally clicked "problem solved" when posting my
reply. I'm not finding a way to undo the "Solved" status. Is that
something you have to do from your end?

On 2014-01-16 07:26, moma wrote:
> Your question #241801 on Audio Recorder changed:
> https://answers.launchpad.net/audio-recorder/+question/241801
>
> Status: Open => Needs information
>
> moma requested more information:
> Hello,
> Would you please copy&paste the timer commands here. I will then
> figure out how to debug the timer module.

moma (osmoma) said : #4

This issue is beeing investigated.

moma (osmoma) said : #5

You are right. There is a bug in the timer.c module.
I will fix it and roll out new packages soonest possible. I will let you know when it^s done.

Best moma (osmoma) said : #6

Re-hi,
This bug has been addressed by revision #349.
See: http://bazaar.launchpad.net/~osmoma/audio-recorder/trunk/revision/349

Launchpad.net has now received a request to compile audio-recorder version 1.4-2.
Please wait till A.r has been compiled for both i386 and x64.
You can check the status of compilation here:
https://launchpad.net/~osmoma/+archive/audio-recorder/+packages

Then update your package index and packages
sudo apt-get update
sudo apt-get upgrade

Many thanks for your bug-report.

raydar (raydar) said : #7

Thanks moma, that solved my question.

FM33 (foxxm) said : #8

Where can i download 1.4-2 source code ? "All downloads jumps from 1.4-1 to 1.5-4

moma (osmoma) said : #9

Hello,

You can download the source for a specific revision number.
Make a new directory and get the code with -r # option. For example get
revision 355.
$ mkdir TEST; cd TEST
$ bzr branch lp:audio-recorder -r 355

Just take the latest revision # for your distro. Please see
http://bazaar.launchpad.net/~osmoma/audio-recorder/trunk/changes/359?start_revid=479

Kindly
  Osmo (Moma) Antero
  Portugal

On Tue, Jan 13, 2015 at 11:41 PM, FM33 <<email address hidden>
> wrote:

> Question #241801 on Audio Recorder changed:
> https://answers.launchpad.net/audio-recorder/+question/241801
>
> FM33 posted a new comment:
> Where can i download 1.4-2 source code ? "All downloads jumps from 1.4-1
> to 1.5-4
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
// moma
   http://www.futuredesktop.org