Zim

Pages keep reapearing

Asked by Michael Kramer on 2017-01-27

Hi,

I love zim, this is a great tool, and I cannot do without anymore, so, first of all thanks to the developer (s).

I am having an issue with deleting pages from a notebook.
For this notebook, I work on windows 10 with a portable version.

I have read the manual and FAQs over and over, and, I am not finding a solution.
As far as I read, pages can reappear for two reasons, first, other pages link to them, second, notebook version has been saved.

The thing is, the notebook is only a structure I am working on with customized templates, but no content whatsoever,
so no other pages can link to them.

Furthermore, none of the pages I cannot delete have back links; there is no link in the notebook anyway..

The only thing they contain are headers, and tags too; those are pages I used to build templates quickly , and then, edit them with N++.

So, unless tags can mess with the index, all that is left (to my little knowledge) is the saved version mentioned in the manual.
I do not think I have a saved version of this notebook since, for what I understood, it is a feature related to the versioning plugin which is in my case disabled.

What I tried so far:
Deleting pages, exit zim, clean the cache, empty the bin ... Not successful.
Deleting the pages within file explorer in the notebook folder .. They instantly reappear even though zim is not running.

Please note that I am using other notebooks on this windows machine, and there has been no issue so far.

I really hope I am missing something obvious that you will point out to me...

If not, I will rebuild a notebook from scratch since there is no lost content, just a couple of days work, but if this was the case, is there a way to prevent this from happening in the future?

Thank you for your time, and this great app.

Question information

Language:
English Edit question
Status:
Solved
For:
Zim Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Kramer
Solved:
2017-01-31
Last query:
2017-01-31
Last reply:
Michael Kramer (lyndhurst) said : #1

Hi,
I am coming back to mark the problem as solved.
It turns out the issue I encountered had nothing to do with zim, but was simply caused by an improperly set Rsync Job I had running in the background.
I do not know where my head was, and I am sorry for the post, but, I really felt stuck there.
Thanks again for this great app.