Zim

problems with TreeView and LinkMap

Asked by Richard Hainsworth on 2016-05-05

Using ubuntu 16.04, zim 0.65

I cannot get TreeView to work. Downloaded the python code where required. Activated plugin. Added pydot and GraphViz dependencies.

Launched plugin on a zim page. The input dialog works. But preview does not work, and on close I get the error behavour of saving the input.

I tried changing the input to something simpler. On investigating further, I found the file treeview.tab, but no dot file.

I think that the failure is in the dot sequence. TreeView uses twopi. So I checked that twopi works from a terminal, it does. So the GraphViz part is OK.

I tried to change the code for InsertGraph, which directly uses GraphViz, substituting 'neato' or 'twopi' in place of dot.

Neither of these work. Somehow I can't get the system to call neato or twopi within zim.

I am not a python person, so I find the code difficult to understand. Nor can I work out how to get debug information out of the system.

Question information

Language:
English Edit question
Status:
Answered
For:
Zim Edit question
Assignee:
No assignee Edit question
Last query:
2016-05-05
Last reply:
2016-05-09

Afraid this is not a standard supported plugin, so can't help you troubleshooting. Please refer to the author, or try the mailing list.

Regards,

Jaap

Can you help with this problem?

Provide an answer of your own, or ask Richard Hainsworth for more information if necessary.

To post a message you must log in.