Zim unable to resolve ditaa dependency

Asked by Brad Adkins

I have downloaded the ditaa jar (named ditaa0_9.jar) I have copied that file to both jdk and jre lib and lib/ext directories. I have also stored the jar file in a local directory and referenced that in my CLASSPATH. Despited all of these locations Zim can not resolved ditaa. This is likely becuase Java can't either! When I type this: "java -jar ditaa0_9.jar" Java says it can't locate the jar. So it seems I have not properly installed the jar so Java can find it. (Yes this appears to be a Java problem stemming from my ignorance :-) I would appreciate some help with installing ditaa jar file so Java (and) Zim can locate it. Thanks!

Question information

English Edit question
Zim Edit question
No assignee Edit question
Solved by:
Jaap Karssenberg
Last query:
Last reply:
Revision history for this message
Brad Adkins (bradjadkins) said :

Also, should the jar be renamed "ditta.jar" for some reason?

Revision history for this message
Best Jaap Karssenberg (jaap.karssenberg) said :

Afraid I can't help you with installing java - not my strong point either.

Zim is looking for an executable called "ditaa.xxx" where the "xxx" can be "exe", "com", "bat", "cmd" or any extension listed in the evironment variable $PATHEXT.

So you need to have an executable that is recognized by you system. Best way to test is simply typing "ditaa" in the command prompt. If that finds an executable, zim should as well.



Revision history for this message
Brad Adkins (bradjadkins) said :

Thank you for the response. I got it working by modifying line 22 in ditaaeditor.py as follows:

dotcmd = ('java -jar /home/adkinsb/local/jar/ditaa0_9.jar')

I'm running on Red Hat 6.6.


Revision history for this message
Brad Adkins (bradjadkins) said :

Thanks Jaap Karssenberg, that solved my question.