Zim

Using a hosted Mercurial repository (e.g., Bitbucket)

Asked by RDNielsen on 2016-01-15

To put an existing Zim wiki under version control (using Mercurial hosted on Bitbucket), I:
1. Created the repository on Bitbucket.
2. Created and initialized a local directory, and committed and pushed a file to verify that the directory was properly under version control.
3. Copied into that directory the entire directory tree and files from an existing Zim wiki.
4. Committed and pushed all the files to Bitbucket from the command line (successfully).
5. Enabled the version control plugin in Zim.
6. Opened up the version-controlled copy of the wiki.
7. Edited a page and used the File/Save version command.

The revision was not pushed to the Mercurial repository on Bitbucket. What needs to be done differently?

[Edit] After running "hg push" at the command line in the repository is updated. The "File/Save version" apparently does not issue the "push" command. Should it?

Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Zim Edit question
Assignee:
No assignee Edit question
Solved by:
Jaap Karssenberg
Solved:
2016-01-15
Last query:
2016-01-15
Last reply:
2016-01-15

At the moment the plugin only does the "commit", so indeed you still need to push manually.

Logic is that you may want to do many edits before you push.

Probably this asks for an option in the plugin to push always, or wait for a menu trigger.

RDNielsen (rdnielsen) said : #2

Thanks Jaap Karssenberg, that solved my question.