Zim

Zim using epiphany-browser instead of iceweasel.

Asked by Gilbert Sullivan on 2010-09-10

Zim 0.48 running in Debian testing (fully up-to-date) with Xfce desktop environment.

I have been using Zim for some time and have had no difficulty printing from Zim by using <Ctrl>+P to get a page displayed in iceweasel and then using <Ctrl>+P again to print from the browser.

Yesterday I installed epiphany-browser from the Debian repositories. The default browser setting was not changed. In Xfce's preferred applilcations iceweasel is still listed as the default browser. Iceweasel itself still "thinks" that it is the default browser.

However, when I try to print from within Zim an epiphany-browser window opens with the Zim page contents. I have tried changing the browser setting in the applications tab of Zim's preferences dialog, to no avail.

If I go to the plugins of the preferences dialog I see that the "Configure" button is grayed out. I never noticed before whether or not that is usually the case.

I also looked at various Zim configuration files under ~/.config/zim and under /usr/share/zim. (I'm not sure if there are other configuration file locations.)

Would someone be able to suggest a way I might get control of which browser Zim uses for printing pages?

Thanks,
Gilbert

Question information

Language:
English Edit question
Status:
Solved
For:
Zim Edit question
Assignee:
No assignee Edit question
Solved by:
Jaap Karssenberg
Solved:
2010-09-10
Last query:
2010-09-10
Last reply:
2010-09-10

The Configure button is grayed out because this plugin has no
configuration. You would need to change the web browser set in the
"Applications" tab. Probably this is still "Default (xdg)" - in that
case it uses xdg-open, which in theory should follow the Xfce
defaults. You could try opening the file from a terminal using
xdg-open or exo-open -- if those are correct, zim should follow.

-- Jaap

Gilbert Sullivan (whirlygig) said : #2

Hi,

Thanks for getting back to me.

Yes, I have tried changing the browser setting in the applications tab
of Zim's preferences dialog. The File Browser and Email client settings
cannot be changed in their respective dropdowns. But for Web browser I
can select the following:

Firefox Web browser
Default (xdg)
Geany
Epiphany
Default webbrowser

It doesn't matter which one I select. When I hit the <Ctrl>+p key
combination, the Zim page I'm on is displayed in Epiphany. I also tried
opening Zim-related files using both the xdg-open and exo-open commands
in a terminal which gave the following outputs:

$ xdg-open Chips.txt
method return sender=:1.14 -> dest=:1.177 reply_serial=2
$ xdg-open notebook.zim
method return sender=:1.14 -> dest=:1.180 reply_serial=2
$ exo-open Chips.txt
method return sender=:1.14 -> dest=:1.186 reply_serial=2
$ exo-open notebook.zim
method return sender=:1.14 -> dest=:1.188 reply_serial=2

Both the xdg-open and exo-open commands issued against a text file
displayed the file in a text editor (Geany on this system).

Both the xdg-open and exo-open commands issued against the related
notebook.zip file displayed the file in Zim.

Printing from within the notebook still displayed the file in Epiphany.

If I understand you properly, then I've already done everything that can
be done from within Zim to correct this issue. I'm guessing my problem
is with some configuration within Xfce, but all of the behaviors in the
DE lead me to believe that it's correct. If I click on an http link in
an e-mail the default browser (Iceweasel) opens, etc.

Thank you for your time. This isn't a serious issue at all, but it is
perplexing. Odd little mysteries like this bother me a bit.

For example, I have seen certain other very minor irregularities in the
interface within Zim with these same five Xfce systems. (<Shift>+<F12>
puts a red "x" in a checkbox, <F12> alone puts a green checkmark in a
checkbox, but no combination of keys with <F12> will cause the checkbox
to revert to being unmarked. Mouse clicks work just fine for properly
marking checkboxes, so it's not a big deal.

I do prefer the print from within Icewease over what I get from
Epiphany, but I can correct that problem by changing Epiphany's font
settings.

Best regards,
Gilbert.

Hmm - double checked the code and found that the plugin does indeed
not use the default setting in zim. This is definitely a bug.

On Fri, Sep 10, 2010 at 7:27 PM, Gilbert Sullivan
<email address hidden> wrote:
> Question #124905 on Zim changed:
> https://answers.launchpad.net/zim/+question/124905
>
>    Status: Answered => Open
>
> Gilbert Sullivan is still having a problem:
> Hi,
>
> Thanks for getting back to me.
>
> Yes, I have tried changing the browser setting in the applications tab
> of Zim's preferences dialog. The File Browser and Email client settings
> cannot be changed in their respective dropdowns. But for Web browser I
> can select the following:
>
> Firefox Web browser
> Default (xdg)
> Geany
> Epiphany
> Default webbrowser
>
> It doesn't matter which one I select. When I hit the <Ctrl>+p key
> combination, the Zim page I'm on is displayed in Epiphany. I also tried
> opening Zim-related files using both the xdg-open and exo-open commands
> in a terminal which gave the following outputs:
>
> $ xdg-open Chips.txt
> method return sender=:1.14 -> dest=:1.177 reply_serial=2
> $ xdg-open notebook.zim
> method return sender=:1.14 -> dest=:1.180 reply_serial=2
> $ exo-open Chips.txt
> method return sender=:1.14 -> dest=:1.186 reply_serial=2
> $ exo-open notebook.zim
> method return sender=:1.14 -> dest=:1.188 reply_serial=2
>
> Both the xdg-open and exo-open commands issued against a text file
> displayed the file in a text editor (Geany on this system).
>
> Both the xdg-open and exo-open commands issued against the related
> notebook.zip file displayed the file in Zim.
>
> Printing from within the notebook still displayed the file in Epiphany.
>
> If I understand you properly, then I've already done everything that can
> be done from within Zim to correct this issue. I'm guessing my problem
> is with some configuration within Xfce, but all of the behaviors in the
> DE lead me to believe that it's correct. If I click on an http link in
> an e-mail the default browser (Iceweasel) opens, etc.
>
> Thank you for your time. This isn't a serious issue at all, but it is
> perplexing. Odd little mysteries like this bother me a bit.
>
> For example, I have seen certain other very minor irregularities in the
> interface within Zim with these same five Xfce systems. (<Shift>+<F12>
> puts a red "x" in a checkbox, <F12> alone puts a green checkmark in a
> checkbox, but no combination of keys with <F12> will cause the checkbox
> to revert to being unmarked. Mouse clicks work just fine for properly
> marking checkboxes, so it's not a big deal.
>
> I do prefer the print from within Icewease over what I get from
> Epiphany, but I can correct that problem by changing Epiphany's font
> settings.
>
> Best regards,
> Gilbert.
>
> --
> You received this question notification because you are an answer
> contact for Zim.
>

Gilbert Sullivan (whirlygig) said : #4

Thank you for the information.

In the meantime, the workaround (changing fonts in Epiphany) is easy.

Best regards,
Gilbert

Gilbert Sullivan (whirlygig) said : #5

Thanks Jaap Karssenberg, that solved my question.