Launching the Zeitgeist Engine

Asked by Calvin Mitchell on 2009-12-02

OK...I've compiled and installed the Zeitgeist Engine...how do I get it running?

When i run zeitgeist-daemon i get the following error:

Traceback (most recent call last):
  File "/usr/local/bin/zeitgeist-daemon", line 30, in <module>
    from zeitgeist import _config
ImportError: No module named zeitgeist

Question information

Language:
English Edit question
Status:
Solved
For:
Zeitgeist Framework Edit question
Assignee:
No assignee Edit question
Solved by:
Siegfried Gevatter
Solved:
2010-01-05
Last query:
2010-01-05
Last reply:
2010-01-05
Seif Lotfy (seif) said : #1

open a terminal and run "zeitgeist-daemon"

Siegfried Gevatter (rainct) said : #2

I guess you either didn't install it correctly or your Python PATH is messed up.

If you're running Ubuntu or Debian, I'd recommend giving the packages from https://launchpad.net/~zeitgeist/+archive/ppa a try:

 - https://launchpad.net/~zeitgeist/+archive/ppa/+files/zeitgeist-core_0.3.0-0ubuntu1~ppa1_all.deb
 - https://launchpad.net/~zeitgeist/+archive/ppa/+files/zeitgeist-datahub_0.3.0-0ubuntu1~ppa1_all.deb

dascheer (dascheer) said : #3

Installed zeitgeist through synaptic on karmic. Ran "zeitgeist-daemon" and received this error:

DEBUG:zeitgeist.engine:Creating engine 'querymancer'
INFO:zeitgeist.engine:Creating database: /home/user/.local/share/zeitgeist/database.sqlite
DEBUG:root:Checking for another running instance...
DEBUG:root:No running instances found.
INFO:root:Starting Zeitgeist service...
DEBUG:zeitgeist.logger.datasources.firefox:Monitoring Firefox's history: /home/user/.mozilla/firefox/4r8pqtbc.default/places.sqlite
DEBUG:zeitgeist.logger.database.tomboy:Watching for Tomboy notes in "/home/user/.tomboy".
DEBUG:zeitgeist.logger.database.tomboy:Can't run DataProvider for Tomboy, is Tomboy installed? (error: [Errno 2] No such file or directory: '/home/user/.tomboy')
DEBUG:zeitgeist.logger.datasources.evolution:Monitoring Evolution: /home/user/.evolution/mail/local/folders.db
DEBUG:root:Updating database with new Firefox History items
DEBUG:zeitgeist.engine.engine_base:Inserted 0 items in 0.00098 s.

Bummed I really wanna check it out...

Best Siegfried Gevatter (rainct) said : #4

@ dascheer:

First of all, thanks for trying out Zeitgeist!

In the future, please open a new question for your problem, though, instead of commenting on another one, as they may (like in this case) be unrelated.

From the output you posted everything looks good, I'm not sure why you aren't getting any events. Does it insert something if you open files with Gedit / Eye of GNOME / Totem / etc?

Also, the version in Karmic is terribly outdated, and incompatible with the latest code. I'd recommend trying the most recent code. You can download it running "bzr get lp:zeitgeist", update it with "bzr pull" and run it by executing "./zeitgeist-daemon.py" inside the "zeitgeist" directory which the first command will have created.

Finally, if what you are looking for is the Graphical User Interface see: https://launchpad.net/gnome-activity-journal. Zeitgeist itself is only a daemon.

Calvin Mitchell (calvin674) said : #5

Mr. Gevatter: Thank you very much for taking the time to provide a solution!