How to install

Asked by Anders Johansson

This may be obvious to most people, but not to a relative Linux newbie. I have been trying to install Zeit on a Raspberry Pi 2+ but fail no matter what. First off I tried Raspbian, nope, so I tried using Lubuntu and Xubuntu, but they all end up at the same place. I add the ppa but when I go apt install, or aptitude install I get a reply that the packet isn't there. Just to verify I did the exact same thing on my Linux Mint machine and it installed straight away. Building from scratch ends up me fighting the dependency hydra, solve one and you face two new. Worst thing, some of them installed from what I can see is the default repository, but still give me an older version than the one I need. I guess 16.04 is a dead end. Newer linux versions are either not available for Raspberry Pi or won't play nice with my 2+. Is there any other way to install Zeit that isn't apt or git?

(The obvious answer is learn Cron, and yes I will, but I am not the target for this experiment. I would like to get as close as possible to a coffee machine, add coffee and water, push button, add time setup, push Ok. :) )

Question information

English Edit question
Zeit Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said (last edit ):

As far as I know, Raspberry Pis are based on arm CPU architecture, but the PPA provides the Zeit packages only for amd64 CPU architecture.

I assume that you have to compile the software yourself.
Either download the source from github, see
or download the Ubuntu source and build it locally.

Revision history for this message
Anders Johansson (biblib) said :

Ok, so where do I find the Ubuntu source? Feel a bit stupid here, but the only ways I have found are APT and GIT. In my most recent attempt I installed Ubuntu Mate 18.04, the latest Ubuntu baste distro I have found so far, that runs on a Pi. This solved quite a few of my dependency issues, but I'm still stuck with one that complains about KF5::AuthCore not being present in... a few places. I'm at work right now so I can't check, but cmake errors out.

Sadly I have only found two tools for Linux that appear to do the job the way I want it, Zeit and Gnome Schedule, both refuse to compile. There are few Windows applications that could work too, but I end up in a similar hell trying to make Wine play nice on the Pi, because an ARM processor isn't x86 and memory is handled differently than on a PC (2G/2G etc).

Revision history for this message
Manfred Hampl (m-hampl) said :

The Ubuntu source is at

if you provide details about the compilation problems and errors, then we can try to help.

For the KF5::AuthCore error you may be missing the package libkf5auth-dev, but it seems that KF5::AuthCore is available only for Ubuntu 20.04 and newer.

Can you help with this problem?

Provide an answer of your own, or ask Anders Johansson for more information if necessary.

To post a message you must log in.