yawls crashes on calibration

Asked by tristank

I installed yawls with

$ sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C90ED941
$ sudo sh -c 'echo "deb http://ppa.launchpad.net/thedsweb/yawls-daily/ubuntu trusty main" >> /etc/apt/sources.list.d/yawls.list'
$ sudo apt-get update
$ sudo apt-get install -y yawls

and then followed your instruction to calibrate it with

$ sudo yawls -c

but it crashed with following output:

Exception in thread "main" java.lang.UnsatisfiedLinkError: no opencv_java248 in java.library.path
 at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1886)
 at java.lang.Runtime.loadLibrary0(Runtime.java:849)
 at java.lang.System.loadLibrary(System.java:1088)
 at com.blogspot.thedsweb.engine.Brightness.<clinit>(Unknown Source)
 at com.blogspot.thedsweb.main.Yawls.automatic(Unknown Source)
 at com.blogspot.thedsweb.main.Yawls.main(Unknown Source)

I'm running Vivid with Linux 3.19.6 #1 SMP Wed Apr 29 11:04:21 MDT 2015 x86_64 x86_64 x86_64 GNU/Linux

Any suggestions?

Question information

English Edit question
Yawls Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #1459737.

Revision history for this message
Dominik Brämer (thedsweb) said :

That is the daemon of yawls which was introduced in version 1.1.0 it start automatically on bootup and is customizable with this file "/etc/yawls.properties" but if you prefers cron you can disable the daemon with:

$ sudo update-rc.d yawls-cli disable

That should fix your problem but check out the config of the daemon it makes the program more flexible to fit your needs but than you have to disable the cronjob again.

Revision history for this message
Dominik Brämer (thedsweb) said :

Used old version of yawls the new one fix the problem