Encountered problems while compiling Yade.

Asked by Xue

Hello everyone,

I am writing to seek help with installing the Yade from source code on Ubuntu 18.04. The source code was downloaded on February 23, 2023. I made modifications to the polyhedra02.cpp file and its corresponding hpp file, and encountered errors during the compilation and installation process following the installation instructions.

Specifically, I encountered the following issues:

After entering the command "sudo add-apt-repository ppa:yade-users/external" and "sudo apt-get update", I received the following error message:
Error:7 http://ppa.launchpad.net/yade-users/external/ubuntu bionic Release
  404 Not Found [IP: 80]
Reading the package list... Done
E: The repository "http://ppa.launchpad.net/yade-users/external/ubuntu bionic Release" does not have a Release file.
N: This source cannot be used securely for updates, so it is disabled by default.
N: See the apt-secure(8) manual for details on repository creation and user configuration.
After installing the external software listed in the Prerequisites, I encountered the following error during the Yade compilation process:
/home/x/myYade/trunk/pkg/dem/CapillaryPhysDelaunay.cpp: In function ‘boost::python::api::object boost::python::detail::make_function_dispatch(F, const CallPolicies&, const Signature&, mpl_::false_) [with F = boost::python::detail::member<double, yade::ElastMat>; CallPolicies = boost::python::default_call_policies; Signature = boost::mpl::vector3<void, yade::ElastMat&, const double&>]’:
/home/x/myYade/trunk/pkg/dem/CapillaryPhysDelaunay.cpp:34:1: internal compiler error: 段错误
 } // namespace yade
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.
CMakeFiles/pkg_dem.dir/build.make:121: recipe for target 'CMakeFiles/pkg_dem.dir/pkg/dem/CapillaryPhysDelaunay.cpp.o' failed
make[2]: *** [CMakeFiles/pkg_dem.dir/pkg/dem/CapillaryPhysDelaunay.cpp.o] Error 1
CMakeFiles/Makefile2:356: recipe for target 'CMakeFiles/pkg_dem.dir/all' failed
make[1]: *** [CMakeFiles/pkg_dem.dir/all] Error 2
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2

Regarding the above errors, I have two questions:
1) How can I solve the above problems?
2) As the compilation process has partially completed (build folder has generated some files), do I need to delete the generated files (or registry entries created elsewhere) before recompiling?

Thank you for your kind assistance.


Question information

English Edit question
Yade Edit question
No assignee Edit question
Solved by:
Jan Stránský
Last query:
Last reply:
Revision history for this message
Best Jan Stránský (honzik) said :


> Ubuntu 18.04

consider upgrade (but probably it is not necessary)

> I made modifications ...

If compiling from source, first try to compile the original unchanged code.
Then, if everything works all right, compile with changes.

> internal compiler error: 段错误

this might be memory problem.
How do you compile it?

could you please provide English translation of 段错误?

> do I need to delete the generated files (or registry entries created elsewhere) before recompiling?

It should not be necessary (but you can do it).


Revision history for this message
Xue (1q12) said :

Thanks Jan Stránský, that solved my question.