questions about examples/ThermalEngine/noFlowScenario.py

Asked by Ziyu Wang

Dear all,

I use yadedaily:
Yade 20210909-5909~5b11526~focal1
Using python version: 3.8.10 (default, Jun 2 2021, 10:49:15)
[GCC 9.4.0]
Ubuntu 20.04

I have read the paper[1] and want to reproduce the simulation.But when I run the script in [2], several errors occurred.
1. When I run the script for the first time, it prompts:FileNotFoundError: [Errno 2] 没有那个文件或目录: 'txt09-19-2021-noFlowScenario//home/wzy/Docx/yade/By_myself/ThermalEngine/NoFlowScen/noFlowScenario.py'
I guess this error may be related to shutil.copyfile() function so I deleted this function
2.When I ran the script again, another error appeared:infinite K1!
I searched on the forum and found [3].Is this error related to regular packing?But in the paper[1], regular packing is used.
3.In the simulation, the dynamic=false of the sphere is set.I don't particularly understand why?

Many thanks for your help.
Best regards.

[1]https://www.sciencedirect.com/science/article/abs/pii/S0045782520304771
[2]https://gitlab.com/yade-dev/trunk/-/blob/master/examples/ThermalEngine/noFlowScenario.py
[3]https://answers.launchpad.net/yade/+question/685486

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Ziyu Wang
Solved:
Last query:
Last reply:
Revision history for this message
Robert Caulk (rcaulk) said :
#1

Hello Ziyu,

Thanks for clearly describing your question.

1.) yes this is something to do with which directory you are in when you execute the code. IT is designed for you to execute the code from inside the examples folder. In other words, you need to use the command "cd" in the terminal to get to the thermal engine examples folder.

2.) Yes, this is expected, commented and documented at the top of the file you reference, and not an issue.
"# note: warnings for inifiniteK and Reynolds numbers = nan for boundary
# cells in regular packings are expected. It does not interfere with the
# physics, these are warnings NOT errors.
"

3.) This just means the spheres cannot move. This particular script is a validation of conductive heat physics only as is documented in the paper you reference.

Cheers,

Robert

Revision history for this message
Ziyu Wang (ziyuwang1) said :
#2

Thanks Robert.Your answer has solved my problem.