MeasureCapStress does not work

Asked by NgocSon-Nguyen


I use Yade to model unsaturated samples. My current Yade version is 2020.01a. I use the engine MeasureCapStress. I turn it off when I generate the dry sample and then turn it on when I apply the succion to the sample. I encounter Segmentation fault (core dumped) as soon as I turn it on. I wounder if there is a bug of this engine or I do not use it correctly.

Is there another way to compute the water volume in the sample. I looped over all interactions to compute it.

Vw = 0.0
for itr in O.interactions:

Is this way correct?

Could you please help me?
Thank you in advance

Question information

English Edit question
Yade Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Jérôme Duriez (jduriez) said :


It looks like this previous issue which has been solved since September 2020 (hence after yade 2020.01a).

You need to update your YADE version if you wish to use that Engine. As for the water volume, your Python measure is correct (for generality, I would just add a "isinstance(itr.phys,CapillaryPhys)" safeguard if I were you)

Revision history for this message
NgocSon-Nguyen (ngocson-nguyen) said :

Hello Jérôme,

Thank you for your answer. I will update my Yade version.

Have a nice day