3D view black

Asked by Raphaël Maurin on 2021-05-04

Hi all,

I am having troubles with the 3D view on my computer: whatever the script I run, with whatever the version of yade (from source, from package, yadedaily), the 3D view opens but it just shows a black square without any particles/objects. There are clearly particles inside the simulation and the simulation runs, it is just the 3D view that seems not to work (without any error message).

In order to give you a precise error script, I get (for example) the problem when running the bouncing sphere example (https://gitlab.com/yade-dev/trunk/blob/master/doc/sphinx/tutorial/01-bouncing-sphere.py) with yadedaily 20210429-5295~8412db8~bionic1. I am on Ubuntu 18.04.

Do you have an idea of what it could be due to ? Do not hesitate if you need further information.
Thanks in advance,

Raphaël

Question information

Language:
English Edit question
Status:
Answered
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bruno Chareyre (bruno-chareyre) said :
#1

Hi Raphaël,
I would suspect graphic card or driver.
Could you try the command "glxgears" (apt install mesa-utils)? Do you see gears or a dark window?
Bruno

Revision history for this message
Raphaël Maurin (raphael-maurin) said :
#2

Hi Bruno,
Thank you for your answer, you seem right, when I execute glxgears, nothing appears on the computer, there is not even a window created (on my other PC, I can see a window opening with some animation).
Should I have a look to the driver of the graphic card ?
Raphaël

Revision history for this message
Bruno Chareyre (bruno-chareyre) said :
#3

> Should I have a look to the driver of the graphic card ?

I have no clue. :)
B

Can you help with this problem?

Provide an answer of your own, or ask Raphaël Maurin for more information if necessary.

To post a message you must log in.