no X rendring on WSl ubuntu

Asked by Abdeldjalil Moubyen

Hi every one

i have successfully installed Yade on WSL ubuntu on windows 10 v19.09, i have installed Vcxsrv to run the GUI

when i run my code the simulation is done but i get this message :

Warning: no X rendering available (see https://bbs.archlinux.org/viewtopic.php?id=13189)

i can't see the graphical interface

i hope you help me

Best regards.

Abdeldjalil

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Anton Gladky
Solved:
Last query:
Last reply:
Revision history for this message
Best Anton Gladky (gladky-anton) said :
#1

Hi,

it is interesting to know that Yade can be running on Windows.
As far as I understand Microsoft has just started to port Linux GUI on Windows and they reported about it yesterday [1].

It would be useful if you share your experience compiling/running Yade on Windows even without GUI.

[1] https://devblogs.microsoft.com/commandline/the-initial-preview-of-gui-app-support-is-now-available-for-the-windows-subsystem-for-linux-2/

Regards

Anton

Revision history for this message
Abdeldjalil Moubyen (abdeldjalil93) said :
#2

Thanks Anton Gladky, that solved my question.

Revision history for this message
Abdeldjalil Moubyen (abdeldjalil93) said :
#3

Hi Anton

Thank you so much for this idea, it solved my problem

I could install Yade on WSL ubuntu 20.04 on Windows 10. the simulation is running without any problem using remote desktop connection

for the installation of WSL , Ubuntu on Windows, and Linux GUI. i followed this video on Youtube and it work with me:

https://www.youtube.com/watch?v=IL7Jd9rjgrM&ab_channel=DavidBombal

you can find all the links and commands in the description box or https://github.com/davidbombal/wsl2/blob/main/ubuntu_gui_youtube#L31

for this method: https://<email address hidden>/msg23028.html
it works too i just unchecked the native opengl choice in the VcxSrx configuration

I recommand the first one , the graphic quality is very good.

thank you again Anton

regards

Djalil