yade on centos

Asked by jsonscript on 2020-03-16

Hello everyone!
   Is there a way to install yade on centos, and if so, is there a tutorial? by the way , how to use cmake?

thans!

Question information

Language:
English Edit question
Status:
Needs information
For:
Yade Edit question
Assignee:
No assignee Edit question
Last query:
2020-03-18
Last reply:
2020-03-18
Robert Caulk (rcaulk) said : #1

>>Is there a way to install yade on centos, and if so, is there a tutorial?

[1]https://answers.launchpad.net/yade/+question/687614

>>how to use cmake?

Assuming you are asking with respect to compiling yade source code - [2]

[2]https://yade-dem.org/doc/installation.html#source-code

jsonscript (jsonscript) said : #2

Thanks for your advice
I'm sorry to answer later,I face this mistake and hope to get some advice.

yadeImportError: libQt5Core.so.5: cannot open shared object file: No such file or directory。
QGLShaderProgram: shader programs are not supported
Errors linking simple shader:
Vertex shader for blitShaderProg (MainWithTexCoordsVertexShader & UntransformedPositionVertexShader) failed to compile
Fragment shader for blitShaderProg (MainFragmentShader & ImageSrcFragmentShader) failed to compile
QGLShaderProgram: shader programs are not supported

Thanks!

Robert Caulk (rcaulk) said : #3

I need your cmake output to help you more, but I assume you don't have libQt5 installed.

Please review [1] if you seek quality assistance in this forum.

[1] https://www.yade-dem.org/wiki/Howtoask

Can you help with this problem?

Provide an answer of your own, or ask jsonscript for more information if necessary.

To post a message you must log in.