Warning. Show 3D doesn't work

Asked by ehsan benabbas on 2020-01-03

Hello,

I am using Ubuntu 18.04, and Yade 2019-08-08.git-775ae74

I try to run following codes. The problem is when the Yade window shows up, after clicking on Show3D button I don't see any packing of particles. In fact I get 2 following warnings as output.

[1] https://gitlab.com/yade-dev/trunk/blob/master/examples/concrete/triax.py
[2] https://gitlab.com/yade-dev/trunk/blob/master/examples/triax-tutorial/script-session1.py

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

OUTPUT:

ehsan@ehsan:~$ /home/ehsan/yade/install/bin/yade-2019-08-08.git-775ae74 net.py
Welcome to Yade 2019-08-08.git-775ae74
Using python version: 3.6.9 (default, Nov 7 2019, 10:44:02)
[GCC 8.3.0]
TCP python prompt on localhost:9000, auth cookie `sukyed'
XMLRPC info provider on http://localhost:21000
Running script net.py
Traceback (most recent call last):
  File "/home/ehsan/yade/install/bin/yade-2019-08-08.git-775ae74", line 336, in runScript
    execfile(script,globals())
  File "/usr/lib/python3/dist-packages/past/builtins/misc.py", line 79, in execfile
    with open(filename, "rbU") as fin:
FileNotFoundError: [Errno 2] No such file or directory: 'net.py'
[[ ^L clears screen, ^U kills line. F12 controller, F11 3D view (press "h" in 3D view for help), F10 both, F9 generator, F8 plot. ]]

In [1]: The constructor with a shareWidget is deprecated, use the regular contructor instead.
<WARNING> InsertionSortCollider:261 virtual void InsertionSortCollider::action(): verletDist is set to 0 because no spheres were found. It will result in suboptimal performances, consider setting a positive verletDist in your script.
<WARNING> Shop:445 static Real Shop::PWaveTimeStep(boost::shared_ptr<Scene>): PWaveTimeStep has not found any suitable spherical body to calculate dt. dt is set to 1.0
The constructor with a shareWidget is deprecated, use the regular contructor instead.

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

Would you please help me with that to be able to see the packing and don't get these warnings?

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Yade Edit question
Assignee:
No assignee Edit question
Solved by:
Robert Caulk
Solved:
2020-01-03
Last query:
2020-01-03
Last reply:
2020-01-03
Robert Caulk (rcaulk) said : #1

"FileNotFoundError: [Errno 2] No such file or directory: 'net.py'"

Means that it cannot find the file 'net.py'.

Best Robert Caulk (rcaulk) said : #2

Make sure you are in the directory where net.py resides before asking yade to run the file.

ehsan benabbas (ehsanben) said : #3

Thanks Robert Caulk, that solved my question.